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SECURITY

As a customer of new telecommunications equipment, you should be aware of the
significant and growing problem of theft of long distance services by third parties,
known commonly as “toll fraud.” It is particularly important that you understand
and take appropriate steps to deal with this crime because under applicable tariffs,
you will be responsible for payment of associated toll charges. AT&T can not be
responsible for such charges and will not make any allowance or give any credit
resulting from toll fraud.

Toll fraud can occur despite the preventive efforts of network providers and
equipment manufacturers. Toll fraud is a potential risk for every customer with
telecommunications equipment having one or more of the following features: (1)
remote access, (2) automated attendant, (3) voice mail, (4) remote administration
and maintenance, and (5) call forwarding (remote). This is not a product or design
defect, but a risk associated with equipment having one or more of the features
described above. If your new telecommunications equipment possesses any of
these features, please consult the relevant portion of your documentation for
further details and specific procedures to reduce the risk of toll fraud or contact
your AT&T dealer for further details.

ORDERING INFORMATION

To order copies of this manual:

Contact: Your AT&T Account Team or your AT&T Authorized Dealer.
or
Call: AT&T at 1-800-432-6600
or
Write: AT&T Customer Information Center

P.O. Box 19901
Indianapolis, IN 46219

Order: Document No. 560-201-101
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Introduction

1

What is PassageWay™ Solution?

AT&T PassageWay™ Solution is a collection of software applications that runs
with Microsoft® Windows™ operating system version 3.1 or later, providing you
with an interface between your lBM® -compatible personal computer and a
MERLIN LEGEND® Communications System via your MLX-28D™, MLX-20L™,
or MLX-10DP™ telephone. PassageWay applications increase your
telecommunication capabilities by providing the following features:

■

■

■

■

■

a software card file that enables you to store names, addresses,
telephone numbers, and other information you desire, place calls directly
from your PC, and keep a log of all the calls you make

the ability to program MLX-station user features for your telephone
quickly and easily from your PC

the ability to maintain a log of the calls you make

autodialing using the Hayes® command set

the ability to use Dynamic Data Exchange to link PassageWay
applications with other Windows applications
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Overview of PassageWay
Applications

PassageWay consists of the following four software applications:

■

■

■

■

AT&TCall
AT&TCall is a card file application that enables you to maintain names,
addresses, telephone numbers, and other information you desire. With
AT&TCall, you can place calls directly from your PC and keep a log of
all the calls you make.

AT&TSet
AT&TSet is a station programming application that enables you to
program user features for your MLX-28D, MLX-20L, or MLX-10DP
telephone from your PC. With AT&TSet, you can create and save
multiple button programming files for your telephone. You can also
exchange these button programming  AT&TSet files with other AT&TSet
users.

Log Viewer
Log Viewer is an application that enables you to access information
from the call log, which stores a record of every call you make while
using AT&TCall.

AT&TConnect
AT&TConnect is the management software that provides the basis for
the other PassageWay software applications, and the diagnostic
features to troubleshoot these applications. AT&TConnect also provides
autodialing using the Hayes command set, which is the same command
set used by most modems. AT&TCall and AT&TSet require
AT&TConnect to be running to connect these applications with the
MERLIN LEGEND system, enabling you to fully use these applications.
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PassageWay Components

PassageWay consists of the following components:

■

■

■

■

■

the PassageWay adapter

The PassageWay adapter provides an interface between your MLX-28D,
MLX-20L, or MLX-10DP telephone and an available serial (COM) port
on your PC. The PassageWay adapter connects to the MLX-28D and
MLX-20L telephones via the DSS interface. The PassageWay adapter
connects to the MLX-10DP telephone via the Adjunct interface.

software (one 3.5-inch, 1.44 MB, high-density diskette and one
5.25-inch, 1.2 MB, high-density diskette)

this user’s manual and a quick reference

a 9-pin to 25-pin adapter for 9-pin serial ports

If your PC has a 9-pin serial port, connect the 9-pin to 25-pin adapter to
the serial port. The PassageWay adapter has a 25-pin connector.

a 4-foot, 4-pair, keyed modular phone cord (D8AC)

This modular phone cord connects the PassageWay adapter to your
MLX telephone. For MLX-28D and MLX-20L telephones, this modular
phone cord connects to the DSS interface. For MLX-10DP telephones,
this modular phone cord connects to the Adjunct interface.
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Figure 1-1 shows the PassageWay components.

9-Pin to 25-Pin Adapter

PassageWay Adapter 4-Foot, 4-Pair Keyed
Modular Phone Cord (D8AC)

Figure 1-1. PassageWay Components
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Figure 1-2 shows the components of the PassageWay adapter.

DB-25
Connector

LED

Modular
Jack

Figure 1-2. Components of the PassageWay Adapter
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PassageWay Requirements

To use the PassageWay applications, you must have the following
components:

—

—

—

—

—

—

—

■

■

■

an IBM-PC compatible or PS/2®-compatible PC with the following
hardware:

an 80286 or higher processor (an 80386 or higher model number
is recommended)

an available serial port

a minimum of 2 MB of RAM

a 3.5-inch, 1.44 MB, high-density drive or a 5.25-inch, 1.2 MB,
high-density drive

a hard disk with 2 MB of space available

a VGA monitor

a Windows-compatible pointing device (a mouse or trackball is
recommended)

Microsoft Windows 3.1 or later release running in standard or enhanced
mode

an MLX-28D, MLX-20L, or MLX-10DP telephone connected to a
MERLIN LEGEND system

Refer to chapter 2 for requirements regarding the MERLIN LEGEND system.

NOTE:
If your PC is located more than 4 feet from your telephone, you will need to
use a standard PC serial cable to connect PassageWay to your PC.
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NOTE:
If all of the serial ports in your PC are already in use, you may wish to
purchase an additional serial port for use with PassageWay. Consult Appendix
B for recommendations on choosing a suitable serial port for PassageWay.

User Responsibilities

Before using any of the PassageWay applications, you should be familiar with
basic Windows functions and procedures. If not, consult your Microsoft
Windows User’s Guide.

You also may need to contact your PC vendor for information on configuring
your PC.

Using this Guide

This guide consists of the following chapters:

Chapter 1 - Introduction

This chapter offers an overview of the PassageWay applications, including
basic components and equipment required.

Chapter 2 - Installing PassageWay

This chapter describes how to install the PassageWay adapter and the
PassageWay applications.

Chapter 3 - Using AT&TCall

This chapter describes how to use AT&TCall.
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Chapter 4 - Using AT&TSet

This chapter describes how to use AT&TSet.

Chapter 5 - Using Log Viewer

This chapter describes how to use Log Viewer.

Chapter 6 - Using AT&TConnect

This chapter describes how to use AT&TConnect.

Chapter 7 - Using Autodialing Applications with PassageWay

This chapter describes how to use autodialing applications with PassageWay.

Chapter 8 - Troubleshooting

This chapter describes how to troubleshoot the PassageWay applications.

Glossary

Appendix A - Menu Trees

This appendix contains menu trees of the PassageWay applications.

Appendix B - PC Serial Ports

This appendix contains general information regarding PC serial ports.

This section defines terms used in this guide.
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Conventions Used in this Guide

The following conventions are used in this guide:

■

■

■

■

■

■

Commands and text you should enter appear in this style of
type.

Values, instructions, and prompts that appear on the screen are in
this style of type.

Key names that are always located on the keyboard in the same place
appear in boxes, as in [ ENTER ↵ ].

Key combinations (holding down one key while pressing another key)
are connected with hyphens; for example: [ CTRL ]-[ ALT ]-[ DEL ].

Only active windows are displayed.

The terms option buttons and radio buttons refer to the same object.

Getting Help

If you have questions about or problems with the PassageWay applications
that this user’s guide does not resolve, call the AT&T National Service
Assistance Center at 1-800-628-2888 or your AT&T Authorized Dealer.
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Installing PassageWay

2

Overview

This chapter provides the procedures for installing PassageWay. Installation

■

■

■

■

consists of the following two steps:

installing the PassageWay adapter, which provides an interface between
your PC and MLX telephone

installing the PassageWay software onto the hard disk of your PC

Before installing PassageWay, make sure you have the following items:

PassageWay adapter

PassageWay software diskette (either a 3.5-inch or 5.25-inch diskette,
depending on the disk drive of your PC)
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Installing PassageWay

■

■

■

9-pin to 25-pin adapter, if you have a 9-pin serial port on your PC

a 4-foot, 4-pair, keyed, modular phone cord (D8AC)

an available serial (COM) port on your PC

Before installing the PassageWay software, you must know the following
information:

■

■

■

■

the model of your telephone (that is, MLX-10DP, MLX-20L, or MLX-
28D).

the software version of your MERLIN LEGEND system (that is, 1.0, 1.1,
or 2.x). You can obtain this information from the manager of your
MERLIN LEGEND system.

the mode in which your switch is operating (that is, Key, Hybrid PBX, or
Behind Switch). You can obtain this information from the manager of
your MERLIN LEGEND system.

the COM port (for example, COM1, COM2, COM3, or COM4) to which
you are connecting the PassageWay adapter.
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NOTE:
The System Manager can determine the software version and operating mode
of the MERLIN LEGEND system using the following procedures.

Software Version
To determine the software version of the MERLIN LEGEND system, perform
the following steps:

1. At any MLX display set, go off-hook on an Intercom or System Access
(SA) button.

You hear intercom tone.

2. Press [ ✱ ] [ 0 ] [ 5 ] on the dialpad.

The display shows the software version of the MERLIN LEGEND
system.

3. Hang up the telephone.

Operating Mode
To determine the mode in which the MERLIN LEGEND system is operating,
perform the following steps:

1.

2.

3.

At the administrator console, press the Menu key.

The MENU MODE: Select Feature Menu appears.

Select Sys Program.

The System Set-up information appears. Note the contents of the
Type: field (that is, Key, Hybrid/PBX, or Behind Switch).

When finished, press the Home key.
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System Requirements

Before installing PassageWay, review the following information:

■

■

■

PassageWay requires your MLX telephone to be wired with 4-pair
station wiring in order to work. Otherwise, local telephone power is
required.

Local telephone power is required if you use a console and DSS
configuration with PassageWay.

Your telephone should have Idle Line Preference activated. With Idle
Line Preference activated, the system automatically selects a line for
outgoing calls when you go off-hook. If Idle Line Preference is activated,
a red LED is lit when your phone is idle. When you go off-hook, a green
LED turns on and you hear dial tone.

To activate Idle Line Preference, perform the following steps:

1. Press the Feature button.

The green LED next to the Feature button turns on.

2. Press [ 0 ] [ 0 ] on the dialpad.

The telephone enters program mode.

3. Press any line/feature button.

4. Press [ ✱ ] [ 3 ] [ 4 ] [ 3 ] on the dialpad.

■

5. Press the Home button.

The automatic line selection on your telephone should be set so that
your Idle Line Preference is on an Intercom button (if your MERLIN
LEGEND system is in Key mode or Behind Switch mode) or an SA
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■

button (if your MERLIN LEGEND system is in PBX mode). By setting
the automatic line selection to an Intercom button or an SA button, you
have the ability to make both internal and external calls via AT&TCall.
(You can make outside calls on an extension or SA button by entering
“9.”) The System Manager can change the automatic line selection.

PassageWay applications can run on a network, but they are not
network aware (that is, PassageWay applications do not support file
sharing). If you are on a local area network (LAN) and have a
workstation with a local hard disk, install the PassageWay software on
the local hard disk. If you are on a LAN and have a workstation that
does not have a local hard disk, install the PassageWay software in
your home directory on your fileserver.

Installing the PassageWay Adapter

The PassageWay adapter provides an interface between the serial port on
your PC and either the DSS interface on your MLX-20L or MLX-28D telephone
or the Adjunct interface on your MLX-10DP telephone, enabling you to access
the MERLIN LEGEND system from your PC. The PassageWay adapter has a
DB-25 connector for 25-pin serial ports. However, if you have a 9-pin serial
port on your PC, AT&T PassageWay provides a 9-pin to 25-pin adapter for you
to use.

To install the PassageWay adapter, perform the following steps:

1. Unplug the line cord from your telephone.

2. Turn off your PC.

3. Connect the DB-25 connector on the PassageWay adapter to the serial
(COM) port on your PC. If your PC has a 9-pin serial (COM) port,
connect the 9-pin to 25-pin adapter to the DB-25 connector on the
PassageWay adapter, and then connect the 9-pin to 25-pin adapter to
the 9-pin serial (COM) port.
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NOTE:
You can use an RS-232 cable to connect the adapter to the PC if
you do not want to connect the adapter directly to the PC or if the
PC is more than 4 feet from your telephone.

4. Connect one end of the 4-foot, 4-pair, keyed modular phone cord
(D8AC) to the PassageWay adapter.

5. Perform one of the following steps:

—

—

If you have an MLX-28D or MLX-20L telephone, connect the
other end of the 4-foot, 4-pair, keyed modular phone cord (D8AC)
to the DSS interface on your telephone.

If you have an MLX-10DP telephone, connect the other end of
the 4-foot, 4-pair, keyed modular phone cord (D8AC) to the
Adjunct interface on your telephone.

6. Reconnect the line cord to your telephone.

7. Turn on your PC.
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Installing the PassageWay Software

The PassageWay software includes an installation program that automatically
installs the PassageWay applications onto the hard disk of your PC. To install
the PassageWay software, perform the following steps:

1. Insert the PassageWay diskette into the diskette drive of your PC.

2. Access Windows.

3. From Program Manager, select Run... in the File menu.

The Run dialog box appears.

Run

Figure 2-1. Run Dialog Box

2-7



Installing PassageWay

4. Depending on the diskette drive in which you inserted the PassageWay
diskette, perform one of the following steps:

— If the diskette is in the A: drive, type a:\setup in the Command
Line box and select the OK button.

— If the diskette is in the B: drive, type b:\setup in the Command
Line box and select the OK button.

The PassageWay Setup dialog box appears.

PassageWay Setup

1.

2.

3.

Welcome to the PassageWay Setup Program.

Before preceding with the installation process, first obtain the following
information (you will be asked to provide this information during the installation
procedure):

The number of the serial port to which your PassageWay Adapter is
connected [e.g., COM1, COM2, etc.]

The model number of your MLX telephone (i.e., MLX-10DP,
MLX-20L, or MLX-28D]

The version number of your MERLIN LEGEND Communications
System [i.e., 1.0, 1.1, or 2.x]

4. The operating mode of your MERLIN LEGEND (i.e., Key, Hybrid/PBX,
or Behind Switch]

If you cannot provide this information at this time, select “Exit” now, and run the
SETUP.EXE program again after you’ve obtained the necessary information.
Your LEGEND system manager can provide the answers for items [3] and [4].

Figure 2-2. PassageWay Setup Dialog Box
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At this point, you must know the following information:

■

■

■

■

the number of the serial (COM) port to which you connected the
PassageWay adapter (for example, COM1, COM2, COM3, or
COM4)

the model number of your MLX telephone (that is, MLX-10DP,
MLX-20L, or MLX-28D)

the software version of your MERLIN LEGEND system (that is,
1.0, 1.1, or 2.x)

the operating mode of your MERLIN LEGEND system (that is,
Key, Hybrid/PBX, or Behind Switch)

You can obtain this information from the manager of your MERLIN
LEGEND system.

5. Select the Continue button.

The PassageWay Directory Setup dialog box appears.

PassageWay Setup

Setup will install this application into the following
directory, which it will create on your hard disk.

If you want to install the application in a different
directory and/ or drive, type the name of the directory
below:

Copy to: C:\PWML

Figure 2-3. PassageWay Setup Directory Dialog Box
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This is the directory in which the PassageWay applications will reside. If
you want to change the default directory for these applications, specify
the directory where you want to place these applications.

6. Select the OK button.

The system loads the PassageWay applications and their associated
files onto the hard disk of your PC. A window appears, displaying the
status of the software installation. After all of the files are loaded, the
Setup message box appears.

Setup

Setup has installed the software successfully
and added the application[s] to the Program
Manager.

Figure 2-4. Setup Message Box
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7. Select the OK button.

The COM Port dialog box appears. Only available COM ports can be
selected; other choices are “grayed.”

COM Port

Select the Communication port for
your PassageWay adapter:

Figure 2-5. COM Port Dialog Box
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8. Select the option button of the COM port to which you connected the
PassageWay adapter, and then select the OK button.

The Configure System dialog box appears.

Configure System

Indicate the following information about your telephone and MERLIN
LEGEND Communications System below:

Figure 2-6. Configure System Dialog Box

9. Select the option button of the type of telephone you have.

10. Select the option button of the version of your MERLIN LEGEND
system.

11. Select the option button of the operating mode of your MERLIN
LEGEND system.
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12. Select the OK button.

The Configure System dialog box closes, and the PassageWay window
appears, displaying the AT&TConnect, AT&TCall, AT&TSet, and Log
Viewer icons. The AT&TConnect icon also appears at the bottom of
your screen.

Figure 2-7. PassageWay Window

The installation program puts the AT&TConnect icon in the Startup group.
Every time you invoke Windows, the AT&TConnect software is automatically
loaded, and the AT&TConnect icon appears at the bottom of the screen.
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You may now run one of the other PassageWay applications.

If you do not want AT&TConnect to be loaded automatically every time you
invoke Windows, remove the AT&TConnect icon from the Startup group
window. (See your Microsoft Windows User’s Guide.) However, if you remove
the AT&TConnect icon from the Startup group window, you must remember to
execute AT&TConnect manually before using other PassageWay applications.
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3

Overview

AT&TCall is a card file application that enables you to maintain information
such as names, addresses, and telephone numbers. You specify the
information that you want to store. With AT&TCall, you can place calls directly
from your PC and keep a log of all the calls you make.

This chapter provides the following information:

■

■

■

■

■

■

a description of AT&TCall

a tutorial describing how to use AT&TCall

helpful hints when using AT&TCall

the procedures for running AT&TCall

the tasks you will perform regularly while using AT&TCall

a description of all the AT&TCall menu options
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Before using AT&TCall, you should consult the following sections of this
chapter

■

■

■

"What Is AT&TCall?," which describes AT&TCall and provides tasks that
you can perform with AT&TCall

"Getting Started," which is a tutorial that shows you how to use
AT&TCall

"Helpful Hints," which provides some "inside" tips and shortcuts that
maximize your time and effort when using AT&TCall

What Is AT&TCall?

As mentioned previously, AT&TCall is a card file application. To understand
how AT&TCall operates, it is helpful to recall how a card file works. A card file
is a unit that stores separate index cards, which are sorted according to
whatever method you want (usually alphabetical order) and contain specific
information you enter. When you obtain a new card file, it is usually empty.
You must then enter data on a card and add the card to the card file.
Eventually, the card file contains a "bank" of cards. If you want to modify a
card in the card file, you must find the card in the card file, remove it, make
your changes, and then place it back to its position in the bank. If you want to
remove a card, you must locate the card in the card file and remove it (usually,
you throw it away).

Each AT&TCall file can be thought of as being a separate card file unit. Each
AT&TCall file contains separate data entries, which are referred to as "cards."
The collection of these cards is referred to as a "bank." Each AT&TCall file can
contain a maximum of 2000 cards in its bank. These cards are sorted in
whatever manner you specify (via the sort option in the View menu) and
contain specific information that you enter. Figure 3-1 shows an untitled
AT&TCall window displaying a blank card. Figure 3-2 shows the components
of an AT&TCall window.
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Figure 3-1. Untitled AT&TCall Window
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List Field File Name Quick DialCard

Previous Arrow Slider Dial Next Arrow

Dial Button

Label Button

Button Button Button

Figure 3-2. Components of an AT&TCall Window
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When you create a new AT&TCall file, it does not contain any cards. The List
field, which lists the cards present in the file, is empty, and the screen displays
a blank card. As with a card file, you must then access a new, blank card (via
the New Card button), enter data on the blank card, and add the new card to
the bank of the AT&TCall file (via the Add Card button).

If you want to modify a card in the AT&TCall file, you must find the card that
you wish to modify, remove it from the card bank, make your changes to the
card (via the Edit Card button), and then place it back in the bank (via the
Return Card button). If you want to delete a card, you must locate the card in
the AT&TCall file and delete it (via the Delete Card option in the Edit menu)
from the bank of the AT&TCall file. If you make changes that you want to save,
you must save the entire card bank to a file (via the Save or Save As options
in the File menu).

Unlike a card file, AT&TCall enables you to perform the following tasks quickly
and easily:

■

■

■

■

■

■

place calls directly from a card

sort cards in a AT&TCall file any way you want

modify the card labels for all the cards in the AT&TCall file

keep track of all the calls you make

include notes for each card

implement passwords to prevent unauthorized use of your AT&TCall
files

Each AT&TCall file also provides a “desktop” with Quick Dials, which are
similar to autodial buttons on your telephone. AT&TCall provides a maximum
of 50 Quick Dials (two sets of 25) per file. However, if you need no more than
20 Quick Dials, you can set AT&TCall to display a maximum of 20 Quick Dials
(two sets of 10). AT&TCall also enables you to hide all of the cards in your
AT&TCall file. In this situation, only the Quick Dials, Hang Up button, Dialpad
button, Timer button, and Quick Shift button (if 50 Quick Dials are used) are
displayed.
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Depending on the number of Quick Dials you specified and whether the card is
hidden, your AT&TCall file desktop can have four different “looks.” Figures 3-3,
3-4, 3-5, and 3-6 show these different desktop looks.

Figure 3-3. Desktop with 10/20 Quick Dials and Card Shown
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Figure 3-4. Desktop with 10/20 Quick Dials and Card Hidden
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Figure 3-5. Desktop with 25/50 Quick Dials and Card Displayed
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Figure 3-6. Desktop with 25/50 Quick Dials and Card Hidden
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Getting Started

If you are using AT&TCall for the first time, it is a good idea for you to perform
the tutorial, which provides the basic procedures for using AT&TCall. This
tutorial takes approximately 15 minutes to complete and shows you how to
perform the following tasks:

1.

2.

3.

4.

5.

6.

7.

8.

9.

10.

11.

12.

Run AT&TCall.

Open an existing AT&TCall file.

Modify an existing card.

Create a new card.

Enter notes for a card.

Make a telephone call from AT&TCall.

Save an existing file.

Create a new file.

Customize the labels in a file.

Assign a telephone number to a Quick Dial.

Save a new file.

Exit AT&TCall.

After completing this tutorial, you will have performed most of the basic
procedures necessary to use AT&TCall.
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Step 1: Running AT&TCall

Before you can perform any AT&TCall tasks, you must run AT&TCall. In order
to run AT&TCall, you must first access Windows and open the program group
that contains the PassageWay applications. To run AT&TCall, just double-click
on the AT&TCall icon. An untitled AT&TCall window appears, displaying a
blank card (Figure 3-7). Figure 3-8 shows the components of an AT&TCall
window.
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Figure 3-7. Untitled AT&TCall Window
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List Field Card File Name Quick Dial

Dial Button

Label Button

Previous Arrow Next ArrowSlider Dial
Button Button Button

Figure 3-8. Components of an AT&TCall Window

At this point, you can either enter information into this new file (by adding new
cards) or open an existing file. For this tutorial, you will open an existing file.
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Step 2: Opening a Existing AT&TCall File

In this step, you will learn how to open an existing file by opening the file
"sample.dex." This file was copied to your PC when you installed the
PassageWay applications.

To open an existing AT&TCall file, perform the following steps:

1. Select Open... from the File menu.

The Open dialog box appears.

2. Select sample.dex from the File Name box and select the OK button.

The AT&TCall file titled "SAMPLE.DEX" appears. This file was copied to
your hard disk during the installation procedure. AT&TCall displays the
last state of the card bank. Whenever you open an existing AT&TCall
file, the system displays the last card that was displayed before you
saved and exited that file.
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Step 3: Editing an Existing Card

In this step, you will learn how to modify the information that is present in an
existing card (that is, a card that was already created and added to the card
bank).

The displayed card information cannot be modified directly. To make any
changes to this information, you must "edit" the card. However, before you can
edit an existing card, you must first locate the card in the bank. AT&TCall
provides several methods for selecting a card:

■

■

■

clicking on the card in the List field

clicking on the Next and Previous arrow buttons located on each side of
the Show Notes button

clicking on the appropriate letter in the Slider, located at the bottom of
the AT&TCall window. For example, if the name you wanted started with
the letter "w," you could click on the "w" on the Slider. The first card that
began with the letter "w" would be selected and displayed.

To edit a card, perform the following steps:

1. Select the card "Kemp,Dave" from the card bank using one of the
methods described above.

The card for Dave Kemp appears.
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Figure 3-9. Card Display

2. Select the Edit Card button, which is located beneath the List field.

The Edit Card window appears and displays all of the information for the
selected card. The cursor is located in the top label field ("Last:"), and
the name "Kemp" is highlighted. The Edit Card button removes the card
from the card bank, enabling you to modify the card.
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NOTE:
In the AT&TCall window, the Edit Card and New Card buttons are
"grayed" while you are editing or adding a card. Only one card
can be "out" of the card bank of an AT&TCall file at one time.

Figure 3-10. Edit Card Window
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You can move the cursor from field to field in the Edit Card window by
performing one of the following actions:

pressing [ TAB →| ] or [ ENTER ↵ ] to move the cursor to the next field

pressing [ SHIFT ]-[ TAB →| ] move the cursor to the previous field

■

■

■ clicking the mouse on the field you want to select

3. Using one of the methods described above, move the cursor to the
"Title:" field, and type Manager.

4. Using one of the methods described above, move the cursor to the
"City:" field, delete Sea Bright, and type Asbury Park.

5. Select the Return Card button.

The Edit Card window disappears, and the changes you made are
displayed. The modified card for Dave Kemp is returned to the bank.
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Figure 3-11. Modified Card
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Step 4: Creating a New Card

In this step, you will learn how to create a new card, enter information into it,
and add the card to the bank.

To add a new card to the card bank, you must get a new, blank card, enter the
data in it, and then add the card to the bank. To add a new card to the card
bank, perform the following steps:

1. Select the New Card button.
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Figure 3-12. New Card Window

2. Type Meyer.

3. Using one of the methods described previously, move the cursor to the
"First:" field, and type Fred.

4. Select the Add Card button.
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The New Card window disappears, the labels for the new card appear
in the List field, and information for the new card is displayed. The new
card is now part of the card bank.

Figure 3-13. New Card
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Now, create a new card for someone you know. When entering information in
the new card, be sure to include that person’s phone number in either the
Office # or Home # field. Enter the phone number the same way as you would
when you are dialing it from your telephone. For example, if you must enter a
"g" before dialing the phone number, include a "9" at the beginning of the
phone number in the card. You will use this new card in Step 6. After creating
this card, select the card "Meyer,Fred" from the card bank, and proceed to
Step 5.

Step 5: Entering Notes for a Card

In this step, you will learn how to enter notes for the card that you created in
Step 4.

AT&TCall enables you to enter notes for each card in a card bank. The Notes
field can contain up to 32K. When a card contains notes, the Notes icon
appears to the left of the Show Notes button. To enter notes for a card,
perform the following steps:

1. Select the Show Notes button.
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Figure 3-14. Note Pad

2. Select Insert Timestamp from the Edit menu.

The time, day, and date are inserted at the top of the note pad.
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3. Type Must call tomorrow, and then select the Hide Notes button.

The card display replaces the note pad. The Notes icon appears to the
left of the Show Notes button, signifying that notes are present for this
card.

Figure 3-15. Card with Notes Icon
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Step 6: Making Calls

In this step, you will learn how to make a call from the card you created in
Step 4 for someone you know and also make a call from the Dialpad.

AT&TCall provides the following ways for you to make phone calls while in a
file:

■

■

■

the Dial buttons on each card

the Quick Dials in the AT&TCall window

the Dialpad

Making a phone call with a Dial button on a card consists of clicking on the
Dial button next to the phone number on the displayed card. To make a call
from a card, perform the following steps:

1. Select the card you created in Step 4 for someone you know.

The card appears.

2. Click on the Dial button next to that person’s phone number.

Your speakerphone activates, and you hear dial tone. AT&TCall then
dials the phone number.

3. Select the Hang Up button to disconnect the call.

Making a phone call with a Quick Dial consists of clicking on the Dial button of
a Quick Dial that you have already programmed with a telephone number.

Making a phone call using the Dialpad feature is similar to dialing a phone
number from your telephone.
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To make a call from the Dialpad, perform the following steps:

1. Select the Dialpad button.

The Dialpad window appears.

Figure 3-16. Dialpad Window

2. Press [ ALT ]-[ K ] on your keyboard or select the Speaker button.

Your speakerphone activates, and you hear dial tone.
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NOTE:
Selecting the Speaker button is the same as pressing the
Speaker button on your telephone (that is, it toggles the
speakerphone on-hook and off-hook).

3 . Using your PC keyboard or clicking on buttons in the Dialpad window,
enter a phone number.

When entering the telephone number, make sure you enter the number
the same way as you would when you are dialing it from your
telephone. For example, if you must enter a "9" before dialing a
telephone number outside of your MERLIN LEGEND Communications
System (that is, an outside call), enter a "9" in the beginning of the
phone number.

AT&TCall passes each digit of the telephone number to the MERLIN
LEGEND system and places the call.

4 . Press [ ALT ]-[ K ] on your keyboard or select the Speaker button to hang
up.

The telephone number you entered is still displayed on the Dialpad. The
telephone number is not cleared when you go off-hook again. To clear
the Dialpad display, press [ C ] on your PC keyboard or select [ C ] on the
Dialpad. The Dialpad display is automatically cleared when you close
the Dialpad window.

Whenever you use the dialpad, you must go off-hook before entering
phone numbers. The system takes the numbers you enter one at a time.
If you enter the phone number and then go off-hook, you hear dial tone,
but the digits you entered are not passed to the MERLIN LEGEND
system. If this occurs, you must re-enter the digits.

5 .
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Step 7: Saving an Existing File

In this step, you will learn how to save to the hard disk of your PC the changes
that you made to the existing file.

Now that you are done modifying the cards in the "sample.dex" file, you must
save your changes to disk. Select Save from the File menu. This procedure
saves the changes you made to "sample.dex" to the hard disk of your PC.

Step 8: Creating a New AT&TCall File

In this step, you will create a new AT&TCall file. New files are empty (that is,
they have no cards in the bank) and untitled. You will use this new file to learn
how to customize the labels of the card display in a file (Step 9).

To create a new AT&TCall file, select New from the File menu. An untitled,
empty AT&TCall file appears. This file is empty and displays a blank card.

Step 9: Customizing the Labels

In this step, you will learn how to customize the labels of the card display of
the new file you created in Step 8.

When you initially access a new AT&TCall file, the system displays the default
labels for the cards (for example, "Last:," "First:," "Title:," and "Company:").
However, you can change these labels at any time, enabling you to create
custom templates for the cards in your AT&TCall files. Whatever changes you
make to the labels apply only to the cards in the AT&TCall file in which you are
working. As a result, you can have AT&TCall files with different labels on their
cards. However, all the cards in the file have the same labels.
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To customize the labels, perform the following steps:

1. Select Edit Labels... from the Setup menu.

The Edit Labels dialog box appears.

Figure 3-17. Edit Labels Dialog Box
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2. Using the methods described previously, move the cursor to Text Field
#7.

3. Delete State:, and enter Country:.

4. Select the OK button.

The Edit Labels dialog box disappears, and the new field label is
displayed on the card template.
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Figure 3-18. Modified Card Labels
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Step 10: Programming a Quick Dial

In this step, you will learn how to program a Quick Dial in the new AT&TCall
file that you created.

AT&TCall enables you to program Quick Dials for each AT&TCall file. Quick
Dials consist of two components: a Label button and a Dial button. The Label
button displays information you want to be displayed on the button (for
example, the person’s name). The Dial button dials the phone number you
specified on the related card. AT&TCall Quick Dials act the same way as
autodial buttons on your telephone.

The card bank in this new AT&TCall window is empty. Since a Quick Dial dials
the phone number from a specified card, you must create a card before you
can program a Quick Dial. To create a card, perform the following steps:

1. Select the New Card button.

The New Card window appears.

2. Fill out the card for someone you know. Make sure you enter a
telephone number for the person.

When entering the telephone number, make sure you enter the number
the same way as you would when you are dialing it from your
telephone. For example, if you must enter a "9" before dialing a
telephone number outside of your MERLIN LEGEND Communications
System (that is, an outside call), enter a "9" in the beginning of the
phone number.
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3. When finished, select the Add Card button.

The new card is displayed.

After creating a card, you can program the phone number for that card to a
Quick Dial. To program a Quick Dial, perform the following steps:

1. Press and hold down [ SHIFT ] and click on a Label button of a Quick Dial.

The Create Quick Dial dialog box appears, displaying the label that will
appear on the Quick Dial Label button and the telephone number that
the Quick Dial will dial. You may modify the label to make it more
descriptive to you and select the option button of the phone number that
you want this Quick Dial to dial (if more than one telephone number is
available).
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Figure 3-19. Create Quick Dial Dialog Box

When programming Quick Dials, you may want to modify the labels. For
example, suppose you want to program a Quick Dial for a friend’s office
telephone number, and also program a Quick Dial for that person’s
home telephone number. If you do not modify the Label buttons when
programming these Quick Dials, you will have two Quick Dials that have
the same labels, but dial different telephone numbers. By looking at the
Label buttons of these Quick Dials, you will be unable to determine
which Quick Dial dials the office telephone number, and which Quick
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2.

3.

4.

Dial dials the home telephone number. In this case, it would make
sense to include terms such as "Home" or "Office" in the labels to
differentiate what each of the Quick Dials will dial.

When finished, select the OK button.

The Create Quick Dial dialog box closes, and the label appears on the
Label button of the Quick Dial.

Click on the Dial button of the Quick Dial that you just programmed.

Your telephone goes off hook, and AT&TCall places the call.

Select the Hang Up button to hang up.

Step 11: Saving a New File

In this step, you will learn how to save the new file to the hard disk of your PC.

To save this new file to disk, perform the following steps:

1.

2.

3.
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Select Save As... from the File menu.

The Save As dialog box appears.

Enter trial in the File Name box.

NOTE:
AT&TCall automatically adds the ".dex" suffix to the file name you
enter. If you prefer, you may enter another suffix. However, it is
recommended that you use the ".dex" default to make it easier to
identify and load AT&TCall files.

Select the OK button.

The Save As dialog box disappears, and "AT&TCall-TRIAL.DEX"
appears in the title bar of the AT&TCall window.
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Step 12: Exiting AT&TCall

In this step, you will learn how to exit AT&TCall.

Now that you have completed the AT&TCall tutorial, exit AT&TCall. To exit
AT&TCall, select Exit from the File menu. The AT&TCall window closes.
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Helpful Hints

Once you have completed the tutorial, refer to the following hints:

■

■

■

Keep all AT&TCall files in the same directory

By default, AT&TCall saves and opens files from the directory in which
the PassageWay applications are installed. By keeping all the AT&TCall
files in the same directory, you can easily access your files.

Determine whether you need more than 20 Quick Dials.

AT&TCall enables you to program a maximum of 50 Quick Dials (two
sets of 25, which are accessed via either the Quick Shift button or the
Quick Shift option in the View menu). However, if you need no more
than 20 Quick Dials, you can set AT&TCall to display a maximum of 20
Quick Dials (two sets of 10, which are accessed via the Quick Shift
option in the View menu). See "Changing the Number of Quick Dials
Displayed," described later in this chapter.

Administer a password for your AT&TCall files.

To prevent unauthorized individuals from accessing your files,
administer passwords for your AT&TCall files. See "Protecting an
AT&TCall File with a Password," described later in this chapter.
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Running AT&TCall

In order to run AT&TCall, you must access Windows and open the program
group that contains the PassageWay applications. To run AT&TCall, just
double-click on the AT&TCall icon. Either an untitled AT&TCall file appears, or
an existing AT&TCall file is automatically loaded. (See "Specifying an
AT&TCall File to be Loaded Automatically," described later in this chapter, to
set AT&TCall to load a specific file automatically.) Refer to the following
section describing the tasks that you will perform regularly while using
AT&TCall.
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Tasks

■

■

■

This section provides the tasks that you will perform while using AT&TCall.
These tasks are grouped into the following categories:

file tasks

card tasks

Quick Dial tasks

Within each category, tasks are presented in alphabetical order.

NOTE:
Before you can perform any of the tasks described in this section, you must
have already accessed AT&TCall.

File Tasks

This section describes the tasks that you will perform when working in an
AT&TCall file. These tasks are presented in alphabetical order.

Accessing the Log Viewer

To access the Log Viewer from AT&TCall, select Call Log from the
Accessories menu. The Log Viewer window appears.

NOTE:
For more information on Log Viewer tasks, refer to Chapter 5.
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Changing How Cards are Sorted in an AT&TCall File

AT&TCall enables you to change the order in which cards are organized in the
card bank. To change how cards are sorted in your AT&TCall file:

1. Select Sort... from the View menu.

The Sort dialog box appears.

Figure 3-20. Sort Dialog Box

2.

3.

4.

Select the First box, and select the label of the field that you want
AT&TCall to sort by first.

Select the Second box, and select the label of the field that you want
AT&TCall to sort by second.

Select the OK button.

The Sort dialog box disappears, and the cards are now sorted in the
card bank according to your specifications.
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Creating a File Template

AT&TCall enables you to create a template for all new AT&TCall files that you
open. Once you create a template, all of your new AT&TCall files will have the
attributes (for example, specific labels or the number of Quick Dials that you
want displayed) that you specified in the template. For example, suppose you
want 25 Quick Dials, a card with your home phone number, and the first Quick
Dial programmed with your home phone number in every file that you create. If
you specify these attributes in your template, every new file that you create will
automatically have 25 Quick Dials, a card with your home phone number, and
the first Quick Dial programmed with your home phone number. At any time,
you can modify or delete this file.

To create a template:

1.

2.

3.

4.

Select New from the File menu.

A new, untitled AT&TCall window appears.

Customize the file to your specifications. For example, modify the labels,
add any cards that you want to appear in all of your new AT&TCall files,
and specify the number of Quick Dials you want in all of your new
AT&TCall files.

When you are finished, select Save As... from the File menu.

The Save As dialog box appears.

Enter attcall.tpl in the Filename box and select the OK button.

The template is now saved. Every new file you open will now contain
the attributes that you specified in your template.
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Creating a New AT&TCall File

To create a new AT&TCall file:

1.

2.

3.

4.

Select New from the File menu.

A new, empty AT&TCall file with the title "(UNTITLED.DEX)" appears.
When you save this file, the system will prompt you to name the file.

Enter your information in this file.

When you are finished working and want to save this file, select Save
As... from the File menu.

The system prompts you to name this file.

Enter the file name in the File Name box, and then select the OK
button.

The name of the file appears in the title bar of the window.

Dialing a Phone Number with the Dialpad

To dial a phone number with the Dialpad:

1.

2.

3.

Select the Dialpad button.

The Dialpad window appears.

Press [ ALT ]-[ K ] on your keyboard or select the Speaker button.

Your phone goes off-hook, and you hear dial tone.

Using your PC keyboard or clicking on buttons in the Dialpad window,
enter the phone number.

When entering the telephone number, make sure you enter the number
the same way as you would when you are dialing it from your
telephone. For example, if you must enter a "9" before dialing a
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telephone number outside of your MERLIN LEGEND Communications
System (that is, an outside call), enter a "9" in the beginning of the
phone number.

AT&TCall passes each digit of the telephone number to the MERLIN
LEGEND system and places the call.

4. When the call is completed, press [ ALT ]-[ K ] on your keyboard or select
the Speaker button to hang up.

The telephone number you entered is still displayed on the Dialpad. The
telephone number is not cleared when you go off-hook again. To clear
the Dialpad display, press [ C ] on your PC keyboard or select [ C ] on the
Dialpad. The Dialpad display is automatically cleared when you close
the Dialpad window.

5. Close the Dialpad window by selecting Close in the Control-menu box
of the Dialpad window.

Exiting AT&TCall

To exit AT&TCall, select Exit from the File menu.

Exporting AT&TCall Information

AT&TCall enables you to export a single card or an entire AT&TCall file to a
file in the comma separated values format (".csv"), which can be used in other
applications. During the export procedure, AT&TCall takes the 12 fields on a
card and the associated Notes field and writes them out in a horizontal line in
a ".csv" file. This line of information from a card is referred to as a “record.” If
you export an AT&TCall file that has 20 cards, the ".csv" file will have 20
records.
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To export an AT&TCall file or card:

1.

2.

3.

Open the file that has the information you want to export.

The AT&TCall window appears.

NOTE:
If you only want to export one card, select that card in the bank.

Select Export from the File menu.

A second menu appears.

Select All Cards... if you want to export the entire AT&TCall file, or
select Current Card... if you want to export the currently displayed
card.

The Export dialog box appears.
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Figure 3-21. Export Dialog Box

4. Enter the name of the file that you want to save this information to and
select the OK button.

The Export dialog box closes, and the new file is created.

Importing Files into AT&TCall

AT&TCall enables you to import files that were created in other applications.
To be imported by AT&TCall, these files must be in the comma separated
values format (".csv"). A ".csv" file consists of "records," which are horizontal
fields of data. Each field of data is separated from the next field by a comma
( , ). Fields containing commas and/or fields consisting of more than one line
must be surrounded by quotes (" "). Each record is one group of related data.
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The end of each record is signified by a carriage return. A ".csv" file can have
numerous fields in a record. However, AT&TCall will only import 13 fields of
data from each record in a ".csv" file. Three records in a ".csv" file may look
like this:

Nolan,Pat,"ABC Travel, Inc."
Ricker,Lisa,"ABC Travel, Inc."
Vidil,Rich,"ABC Travel, Inc."

AT&TCall imports 13 horizontal data fields from the ".csv" file, and then places
the information in the 13 vertical fields of a card in an AT&TCall file (that is, the
12 card fields and the Notes field). If there are more than 13 fields of data in a
record, AT&TCall ignores the remaining data in that record and proceeds to
the next record. If there are less than 13 fields of data in a record, AT&TCall
assumes that the remaining fields in the record are blank and proceeds to the
next record. For example, if each record only contained two fields of
information, AT&TCall would place the information in the first two fields in a
card (for example, the "Last" and "First" label fields) and make the remaining
fields in that card blank. It would then proceed to a new card and enter the
information for the next record.

During the import procedure, AT&TCall scans the file to be imported, verifying
that the file is valid (that is, it is in the correct format) and that only numeric
characters will reside in the telephone number fields (that is, the ninth, tenth,
and eleventh fields) in a card in an AT&TCall file. The telephone number fields
in a card accept all numeric digits, *, #, (,), hyphens, spaces, and commas.

To import a file:

1. Open the AT&TCall file in which you want the imported data to reside.

The AT&TCall file window appears.
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NOTE:
If you are importing data into an existing AT&TCall file, the new
data will be sorted automatically as it is imported. As a result, this
new information will be "mixed in" with your existing information.

2. Select Import... from the File menu.

The Import dialog box appears.

Figure 3-22. Import Dialog Box

3. Select the file that you want to import and select the OK button.

AT&TCall scans the file and then imports the records from the file (if the
file is valid). A dialog box appears, stating the number of cards (that is,
records) that were imported from the ".csv" file.
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Figure 3-23. AT&TCall Dialog Box

4. Select the OK button.

The dialog box closes, and the new information is displayed in the
AT&TCall window.

Opening an Existing AT&TCall File

To open an existing AT&TCall file:

1. Select Open... from the file menu.

The Open dialog box appears, showing a list of the available ".dex" files
in the current directory and disk drive.

2. Select the AT&TCall file you want from the File Name box, and select
the OK button. You may use the drive and directory controls to switch
drives and/or directories.

The file is loaded, and AT&TCall displays the last state of the card bank.
Whenever you open an existing AT&TCall file, AT&TCall displays the
last card that was displayed before you saved and exited that file.
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Printing a Card List

AT&TCall enables you to print a list of the cards in an AT&TCall file. You may
specify the labels of the information that you want printed for each card. For
example, if you want the list to contain the last name, first name, and office #
for each card in the file, you must specify these labels in the Print List dialog
box. In this example, one field would contain "Last:," one field would contain
"First:," one field would contain "Office #:," and the three remaining fields
would each contain "(None)." "(None)" signifies that no label was selected and
that no information will be printed in this field. You may select up to six labels
whose information you want printed.

To print a list of the cards in an AT&TCall file:

1. Select Print List... from the File menu.

The Print List dialog box appears.

Figure 3-24. Print List Dialog Box

2. In each field, select the label of the information that you want printed for
each card.

3. When finished, select the OK button.

Printing begins, and a dialog box is displayed, which enables you to
cancel printing.
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Printing an AT&TCall File or Card

AT&TCall enables you to print either all of the cards in an AT&TCall file or only
the card that is currently displayed. When printing a file or card, you may
specify whether you want the notes associated with the card(s) displayed. If
you specify that you want the notes displayed, the system will print out each
card and its notes on its own page. The top of each page will contain the label
for the card, and the bottom of each page will contain the date, page number,
and file name.

If you specify that you do not want the notes displayed, the system will print
out four cards on each page. The top of each page will contain the labels for
the first and last cards on the page. The bottom of the page will contain the
date, page number, and file name. Figure 3-25 shows how the cards look with
and without the notes printed.
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With Notes

Without Notes

Figure 3-25. Printed Cards With and Without the Notes
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To print an AT&TCall file or card:

1. Select Print Cards... from the File menu.

The Print Cards dialog box appears.

Figure 3-26. Print Cards Dialog Box

—

—

2. Perform one of the following steps:

If you want to print the card that is displayed currently, select the
option button for Current Card.

If you want to print all the cards in the file, select the option
button for All Cards.

3. Select the Print Notes box if you want to print the notes associated with
the card(s).

4. When finished, select the OK button.

Printing begins, and a dialog box is displayed, which enables you to
cancel printing.
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Protecting an AT&TCall File with a Password

AT&TCall enables you to administer a password for each file, preventing
unauthorized people from accessing the file. Passwords may consist of up to
eight printable characters (that is, letters, numbers, and punctuation marks)
and are case sensitive (that is, AT&TCall can differentiate between capital
letters and lowercase letters). After a password is administered for a file,
AT&TCall prompts you to enter a password every time you attempt to access
that file. You may administer passwords for as many AT&TCall files as you
like.

To administer a password for an AT&TCall file:

1. Select Save As... from the File menu.

The Save As dialog box appears.

2. Select the Password button.

The Password Dialog box appears.

Figure 3-27. Password Dialog Box

3. Enter your password and select the OK button.

The Confirm Password dialog box appears.
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Figure 3-28. Confirm Password Dialog Box

4. Re-enter your password and select the OK button.

5. Select the OK button.

The next time you attempt to open this file, AT&TCall will prompt you for
the password.

Removing the Password from an AT&TCall File

To remove the password from an AT&TCall file:

1.

2.

3.

Open the AT&TCall file whose password you want to remove.

The file is loaded.

Select Save As... from the File menu.

The Save As dialog box appears.

Select the Password button.

The Password Dialog box appears.
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4. Delete the password from the Enter Password field and select the OK
button.

5. Select the OK button.

The next time you attempt to open this file, AT&TCall will not prompt
you for the password.

Saving an AT&TCall File

To save any changes to an existing AT&TCall file, select Save from the File
menu. If the file is new, and has not been saved yet, select Save As... from
the File menu.

NOTE:
AT&TCall automatically adds the ".dex" suffix to the file name you enter. If you
prefer, you may enter another suffix. However, it is recommended that you use
the ".dex" default to make it easier to identify and load AT&TCall files.

Setting the Account Code Options

AT&TCall enables you to automate the process of account code entry if your
company uses account codes regularly, or if your telephone is administered for
Forced Account Code Entry (FACE). If you activate an account code option,
AT&TCall will use the contents of the last field (that is, the bottom field) of
each card as the default account code for calls made from that card. If no
account code is present, or the field contains information other than a valid
account code, AT&TCall will prompt you to provide one.
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To set the Account Code options:

1. Select Account Code Options... from the Setup menu.

The Account Code Options dialog box appears.

Figure 3-29. Account Code Options Dialog Box

2. Select the appropriate option button.

3. Select the OK button.
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Setting the AT&TCall Window to Always be on Top of Other Windows

AT&TCall enables you to specify that you want the AT&TCall window to be
located on top of all the other open windows, including the active window. This
option is especially useful when you are using AT&TCall in the Card Hidden
mode and want to keep a set of programmed Quick Dials readily accessible.

To specify that the AT&TCall window is always on top of other windows, select
Always on Top from the Setup menu. A check mark appears next to the
Always on Top option, indicating that the option is activated. The AT&TCall
window will now remain in front of all the other windows you open, even if it is
not the active window.

Setting the Dial Options

AT&TCall enables you to specify a prefix and/or suffix that the system will add
to all telephone numbers dialed via Dial buttons in the associated AT&TCall
file. For example, if you must enter a "9" before dialing a telephone number
outside of your MERLIN LEGEND Communications System (that is, an outside
call), you can specify the prefix “9” in the Dial Option dialog box. However, if
you specify a Dial Option, the system will use that option for each and every
call you initiate from any Dial button in that AT&TCall file. Therefore, if you use
Dial Options, make sure all of the telephone numbers in all of the cards in that
AT&TCall file require the same Dial Option.

To set Dial Options:

1. Select Dial Options... from the Setup menu.

The Dial Options dialog box appears.
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Figure 3-30. Dial Options Dialog Box

2. Select Prefix and/or Suffix, depending on your requirements.

The box next to the option you selected is checked.

3. In the field next to the option you selected, type the prefix or suffix.

4. Select the OK button.

The Dial Options dialog box disappears.

Specifying an AT&TCall File to be Loaded Automatically

AT&TCall enables you to specify a file that will be loaded automatically every
time you access AT&TCall. To specify a file to be loaded automatically:

1. Exit AT&TCall.

2. Locate the AT&T PassageWay group window in Program Manager.
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3. Select the AT&TCall icon with a single click.

The AT&TCall icon is highlighted.

4. Select Properties... from the file menu of Program Manager.

The Program Item Properties dialog box appears.

5. Place the cursor in the Command Line box.

6. Move the cursor to the right-hand end of the Command Line box, after
ATTCALL.EXE.

7. Press the spacebar on your keyboard, and then enter the name,
extension, and path of the AT&TCall file that you want to be loaded
automatically.

NOTE:
You must include .dex at the end of the file name. Otherwise,
the system will be unable to load this file automatically.

Figure 3-31 shows how the Program Item Properties dialog box would
look if you set the “sample.dex” file to be loaded automatically.
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Figure 3-31. Sample File to be Loaded Automatically

8. Select the OK button.

The Program Item Properties dialog box closes. The next time you
access AT&TCall, the file you specified will be automatically loaded.
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Card Tasks

This section describes the tasks that you will perform when working on cards
in an AT&TCall file. These tasks are presented in alphabetical order.

Accessing the Notes Field

AT&TCall enables you to maintain notes for each card. The Notes icon
appears to the left of the Notes button when the card has information in the
Notes field. The Notes field can contain up to 32K. To access the Notes field
for a card:

1.

2.

3.

4.

Select the card of which you want to access the Notes field.

The selected card appears.

Select the Show Notes button.

The Notes field appears.

Enter information in the Notes field or modify the existing information (if
any) in the field.

When you are finished, select the Hide Notes button.

The card is displayed.

Changing the Field Labels in the Cards

AT&TCall enables you to change the field labels for the cards in the bank. This
only applies to the bank you are in. To change the field labels:

1. Select Edit Labels... from the Setup menu.

The Edit Labels dialog box appears.

2. Make your changes.
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3. When you are finished, select the OK button.

The Edit Labels dialog box disappears, and your changes are displayed
on the card.

Creating a New Card

To create a new card:

1.

2.

3.

Select the New Card button.

The New Card window appears, and the cursor is located in the first
field.

Enter the appropriate information in each field that you use.

When you are finished entering information in this card, select the Add
Card button.

The New Card window closes, the labels for the new card appear in List
field, and the information for the new card is displayed.

3-63



Using AT&TCall

Deleting a Card

To delete a card:

NOTE:
When you delete an existing card, all Quick Dials associated with
that card are deleted.

1. Select the card you want to delete.

The selected card is displayed.

2. Select Delete Card from the Edit menu.

The Delete Card dialog box appears.

Figure 3-32. Delete Card Dialog Box

3. Select the OK button.

The card is deleted from the bank, and the next card in the bank is
displayed.
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Dialing a Phone Number from a Card

To dial a phone number from a card:

1. Select the card that contains the phone number you want to dial.

The selected card is displayed.

2. Click on the Dial button located to the right of the phone number that
you want to dial.

AT&TCall places the call. After the call is completed, select the Hang Up
button to place your phone on-hook (that is, to hang up your phone).

Editing an Existing Card

To edit an existing card:

1.

2.

3.

4.

Select the card you want to edit.

The card is displayed.

Select the Edit Card button.

The Edit Card window appears containing the current information for the
card.

Make your changes to the card.

When you are finished, select the Return Card button.

The Edit Card window closes, and the updated card is displayed.
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Hiding the Card Display

AT&TCall enables you to hide the card display and view only the Quick Dials,
the Hang Up button, the Dialpad button, the Timer button, and the Quick Shift
button (if the 25/50 Quick Dial Buttons option is selected). To hide the card
display, select Hide Card from the View menu.

Selecting a Card

You can select any card in the AT&TCall file by performing one of the following
steps:

■

■

■

■

clicking on the entry in the List field

clicking on the Next and Previous arrow buttons that are located on
each side of the Show Notes button

clicking on a letter on the Slider

using the Find and Find Next options from the Edit menu, and the
Next Card, Prev Card, Next Letter, and Prev Letter options
from the View menu

Showing the Card Display

To show the card display after hiding it via the Hide Card option in the View
menu, select Show Card from the View menu.

Using the Timer

AT&TCall provides a stopwatch that enables you to time anything that you
want. You can use the Timer to time the length of a call, but you need to
manually start and stop the Timer. The Timer is not tied to the call.
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To use the Timer:

1. When you want to start the timer, select the Timer button.

The Timer window appears and immediately starts keeping time. The
Timer measures time in hours, minutes, and seconds. To reset the
timer, select the Reset button. To stop the timer, select the Stop button.
To restart the timer after it has been stopped, select the Start button.

Figure 3-33. Timer Window

2. When you are finished using the timer, select Close from the Control-
menu box of the Timer window.
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Quick Dial Tasks

This section describes the tasks you will perform when using Quick Dials in an
AT&TCall file. These tasks are presented in alphabetical order.

Accessing Information for a Quick Dial

To view the information for a Quick Dial:

1. Press and hold down [ SHIFT ], and then click on the Dial button of the
Quick Dial in which you are interested.

The Quick Dial Information dialog box appears. This dialog box presents
the label and phone number for this Quick Dial.

Figure 3-34. Quick Dial Information Dialog Box

2. When you are finished, select the OK button.

If you want to display the card associated with the Quick Dial, click on the
Label button of the Quick Dial in which you are interested. The associated card
is displayed.
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Assigning a Phone Number to a Quick Dial

To assign a phone number to a Quick Dial:

1. Select the card that contains the telephone number that you want to
program to a Quick Dial.

The selected card is displayed.

2. Press and hold down [ SHIFT ], and then click on the Label button of the
Quick Dial that you want to program.

The Create Quick Dial dialog box appears. The system provides a
default label.
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Figure 3-35. Create Quick Dial Dialog Box

3. Enter the label that you want to appear on the Label button of the Quick
Dial.

4. Select the option button of the telephone number that you want this
Quick Dial to dial.
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5. Select the OK button.

The label you entered appears on the Label button of the Quick Dial
you selected.

Changing the Number of Quick Dials Displayed

AT&TCall allows you to program a maximum of 50 Quick Dials (two sets of 25,
which are accessed via either the Quick Shift button or the Quick Shift option
in the View menu). However, if you need no more than 20 Quick Dials, you
can set AT&TCall to display a maximum of 20 Quick Dials (two sets of 10,
which are accessed via the Quick Shift option in the View menu).

To specify the number of Quick Dials you want to access, select either
10/20 Quick Dial Buttons or 25/50 Quick Dial Buttons from the
Setup menu.

Changing the Setup of the Quick Dial Labels

AT&TCall enables you to display the information on the Label buttons of Quick
Dials as left-justified or centered. This setting applies to all AT&TCall files. To
change the setup of the information on the Label buttons of Quick Dials:

1. Select Quick Dial Labels... from the Setup menu.

The Quick Dial Label Setup dialog box appears.
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Figure 3-36. Quick Dial Label Setup Dialog Box

2. Select the option button for the setup you want.

3. Select the OK button.

Dialing a Phone Number from a Quick Dial

To dial a phone number from a Quick Dial, click on the Dial button of the
Quick Dial in which you are interested. AT&TCall places the call. After the call
is completed, select the Hang Up button to place your phone on-hook (that is,
to hang up your phone).
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Erasing a Quick Dial

To erase the label and telephone number assigned to a Quick Dial:

1. Press and hold down [ SHIFT ], and then click on the Label button of the
Quick Dial that you want to erase.

The Change Quick Dial dialog box appears.

2. Select the Erase button.

The information for that Quick Dial is erased, and the Label button for
the Quick Dial is blank.

Re-Assigning an Existing Quick Dial

To assign a phone number to a Quick Dial that has been assigned previously:

1.

2.

Select the card that contains the telephone number that you want to
program to the Quick Dial.

The card is displayed.

Press and hold down [ SHIFT ], and then click on the Label button of the
Quick Dial that you want to change.

The Change Quick Dial dialog box appears.
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Figure 3-37. Change Quick Dial Dialog Box

3. Select the Create New button.

The Create Quick Dial dialog box appears.

4. Enter the label that you want to appear on the Label button of the Quick
Dial.

5. Select the option button of the telephone number that you want this
Quick Dial to dial.

6. Select the OK button.

The label you entered appears on the Label button of the Quick Dial
you selected.
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AT&TCall Menu Bar Options

■

■

■

■

■

■

AT&TCall provides the following options in the menu bar:

File

Edit

View

Setup

Accessories

Help

This section describes the options contained in each AT&TCall menu.
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File

■

■

■

■

■

■

■

■

■

■

The File menu contains the following options:

New

Open...

Save

Save As...

Import...

Export

Print Setup...

Print Cards...

Print List...

Exit

New

Creates a new, empty AT&TCall file. When selected, this option presents a
default screen with no entries. The window title displays "AT&TCall-
(UNTITLED.DEX)."

Open...

Enables you to open an existing AT&TCall file. When selected, this option lists
the existing AT&TCall files. You may scroll through the list and select a specific
file.
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Save

Saves the changes made to the AT&TCall file on which you are working.

Save As...

Prompts you to name the file on which you are working. The default extension
for every AT&TCall filename is ".dex."

Import...

Enables you to import files that are in the comma separated values format
(.csv).

Export

Enables you to export the current card or all cards in an AT&TCall file to a file
that is in the comma separated values format (.csv).

Print Setup...

Displays the Windows printer setup window, allowing you to modify the printer
settings (for example, paper size and print orientation).

Print Cards...

Enables you to print either all cards in an AT&TCall file or the card displayed
currently. When printing the card(s), you may specify whether you want the
notes associated with the card(s) printed also.
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Print List...

Enables you to print specific label fields for each card in an entire AT&TCall
file. You may select a maximum of six labels.

Exit

Exits the AT&TCall application.
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Edit

The Edit menu contains the following options:

■

■

■

■

■

■

■

■

■

■

■

Undo

Cut

Copy

Paste

Insert Timestamp

Clear Notes

Edit Card

New Card

Delete Card

Find...

Find Next

You can use the Undo, Cut, Copy, and Paste options when you are performing
one of the following tasks:

■

■

■

editing an existing card

adding a new card

working in the Notes field of a card
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Undo

"Undoes" the last editing action you performed in a field. For example, if you
change the information in a field and then select "Undo," the field displays its
previous information (that is, the information that was changed).

Cut

Deletes information selected from a field and places it in the Windows
Clipboard while you are editing a card.

Copy

Copies information selected from a field and places it in the Windows
Clipboard while you are editing a card.

Paste

Pastes information from the Windows Clipboard into the current field while you
are editing a card.

Insert Timestamp

Places the day, date, and time in the Notes field for the card displayed. This
information appears in front of the cursor and can be placed anywhere in the
Notes field.

Clear Notes

Erases the contents of the Notes field for the card displayed.

Edit Card

Enables you to edit the card displayed on the screen.
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New Card

Enables you to add a new card to the AT&TCall file.

Delete Card

Enables you to delete the card displayed on the screen.

Find...

Enables you to search for specific characters in each specified field or all fields
on each card in the AT&TCall file.

Find Next

Enables you to find the next card that matches the criteria you specified for the
Find option.
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View

■

■

■

■

■

■

■

■

■

■

The View menu contains the following options:

Hide Card

Show Card

Hide Notes

Show Notes

Quick Shift

Next Card

Prev Card

Next Letter

Prev Letter

Sort...

Hide Card

Displays only the Quick Dials, the Hang Up button, the Dialpad button, the
Timer button, and the Quick Shift button (if the 25/50 Quick Dial Button option
is selected).

Show Card

Displays the entire card along with Quick Dials.
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Hide Notes

Closes the Notes field associated with the selected card.

Show Notes

Displays the Notes field associated with the selected card.

Quick Shift

Enables you to toggle between the first and second set of Quick Dials.

Next Card

Displays the next card in the AT&TCall file (as sorted).

Prev Card

Displays the previous card in the AT&TCall file (as sorted).

Next Letter

Enables you to "jump" to the next letter that contains a card in the AT&TCall
file.

Prev Letter

Enables you to "jump" to the previous letter that contains a card in the
AT&TCall file.
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Sort...

Enables you to specify the primary and secondary labels by which the cards in
your AT&TCall file are sorted.
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Setup

The Setup menu contains the following options:

■

■

■

■

■

■

■

Edit Labels...

Dial Options...

Account Code Options...

Quick Dial Labels...

10/20 Quick Dial Buttons

25/50 Quick Dial Buttons

Always on Top

Edit Labels...

Enables you to modify any of the labels in the card template for your AT&TCall
file. When selected, this option displays a sample card with the current labels.
You may modify any of these labels.

Dial Options...

Enables you to enter a prefix and/or suffix that you want dialed with every
number. For example, if your telephone system requires that first you dial a "9"
before making a call using an outside line, you can specify "9" in the "Dial
Option..." prefix. By specifying your prefix, you do not need to include a "9" in
front of every phone number on every card.
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Account Code Options...

Enables you to administer one of the following account code options:

■

■

■

■

Ignore account codes, which ignores the account code.

Prompt for optional account codes before dialing, which prompts
you to enter an account code before dialing the number.

Prompt for optional account codes after dialing, which prompts you
to enter an account code after dialing.

Prompt for mandatory account codes before dialing (FACE), which
requires that you enter an account code before dialing. If the card does
not have an account code, the system prompts you to enter one.

Quick Dial Labels...

Enables you to display the Label button information for the Quick Dials as left-
justified or centered.

10/20 Quick Dial Buttons

Provides 20 Quick Dials for you to program and use. The system only displays
10 Quick Dials at a time. To access the second set of 10 Quick Dials, select
the Quick Shift option from the View menu.

25/50 Quick Dial Buttons

Provides 50 Quick Dials for you to program and use. When you select this
option, the system only displays 25 Quick Dials at a time. To access the
second set of 25 Quick Dials, either select the Quick Shift button in the lower-
right corner of the AT&TCall window or select the Quick Shift option from the
View menu.
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Always on Top

Keeps the AT&TCall window on top of all other open windows, including the
active window. This prevents the AT&TCall window from being obscured by
other windows.
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■

■

Accessories

The Accessories menu contains the following options:

Call Log

Timer

Call Log

Enables you to access the Call Log, which contains information on all of the
calls you made from an AT&TCall file.

Timer

Displays the Timer window, which contains a timer that immediately starts
running.
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Help

■

■

■

■

The Help menu contains the following options:

Contents

Search for Help on...

How to Use Help

About AT&TCall...

Contents

Displays the topics in on-line Help.

Search for Help on...

Opens the Search dialog box for on-line Help. You can look up Help
information by entering keywords in the dialog box.

How to Use Help

Describes how to use on-line Help.

About AT&TCall...

Displays the AT&TCall version number, Microsoft Window version number,
mode, amount of free memory (KB) available on your system, and the size of
the largest contiguous block of memory (KB) available.
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4

Overview

AT&TSet is a station programming application that enables you to program
user features for your MLX-28D, MLX-20L, or MLX-10DP telephone from your
PC. With AT&TSet, you can create and save multiple button programming files
for your telephone. You can also exchange these button programming
AT&TSet files with other AT&TSet users.

■

■

■

■

■

This chapter provides the following information:

a description of AT&TSet

helpful hints describing how to use AT&TSet

the procedures for running AT&TSet

the tasks you will perform regularly while using AT&TSet

a description of all the AT&TSet menu options
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NOTE:
To use AT&TSet, you should be familiar with MLX station programming. For
more information, refer to the user's guide for your MLX telephone.

What Is AT&TSet?

AT&TSet is a station programming application that enables you to program
user features for your MLX-28D, MLX-20L, or MLX-10DP telephone from your
PC. Each AT&TSet file consists of a screen representation of the buttons on
your telephone. Figure 4-1 shows an AT&TSet file for an MLX-20L telephone.
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Figure 4-1. AT&TSet File for an MLX-20L Telephone

When you run AT&TSet for the first time, the system "reads" the programming
from your telephone and displays an untitled file containing the current
programming for each button on your telephone. When AT&TSet "reads" the
programming from your telephone, it identifies how each button on your
telephone is programmed, providing you with an accurate and up-to-date
status of the programming of your telephone. The untitled file that AT&TSet
displays after reading your telephone is a "workspace" in which you may
modify the programming of your telephone. Every AT&TSet file can be thought
of as a workspace. Figure 4-2 shows the components of an AT&TSet window.
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Button Label Button PositionFile Name

Non-Button Features and Ringing Status Bar

Figure 4-2. Components of an AT&TSet Window
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Each button in an AT&TSet file consists of a button label and a button position.
The button label shows the feature that is programmed to that button, and the
button position specifies the programming status of this button (use or skip).
Use and skip determine whether the feature that is programmed to this button
will be programmed on your telephone. To change the label or feature
programmed to a button, you must first select the button by clicking on the
particular button. When a button is selected, it becomes highlighted. At this
point, you can perform one of the following actions on the button:

■

■

■

change the feature that is programmed to the button (via the Change
Button Programming option in the Programming menu)

change the label of the button (via the Change Button Label option in
the Programming menu)

select the button to be programmed to your telephone (via the Use
Button When Programming option in the Programming menu)

Since AT&TSet files are workspaces, any changes you make to a file are not
immediately programmed to your telephone. To program these modifications to
your telephone, you must "write" the file to the telephone (via the Write to
Telephone option in the File menu). When you write a file to your telephone,
AT&TSet does not automatically program every button in the file to your
telephone. AT&TSet only programs buttons whose button positions display
"use." As a result, you can change how every button is programmed in an
AT&TCall file, but if you select "use" for only one button position, only that
button feature will be programmed to your telephone when you write the file to
your telephone. If you select "skip" for all of the button positions, none of the
button features in that file will be programmed to your telephone when you
write the file to your telephone.

With AT&TSet, you can create button programming files for MLX-28D, MLX-
20L, and MLX-10DP telephones. Regardless of the telephone model you have,
you may create a file for one of the other model types AT&TSet supports. For
example, if you have an MLX-28D telephone, you may create a file for an
MLX-20L or MLX-10DP telephone. AT&TSet also enables you to convert an
existing AT&TSet file to a file for one of the other model types.
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NOTE:
You cannot write a file that was created for one type of telephone to another
type of telephone without first converting the file. For example, if you want to
write a file for an MLX-28D telephone to an MLX-20L telephone, you must
convert the file to a 20-button file before writing the file to the MLX-20L
telephone.

AT&TSet enables you to print labels for the button features programmed on
your telephone. You can print these labels on either a perforated AT&T button
label form or a plain sheet of paper.
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Running AT&TSet

In order to run AT&TSet, you must access Windows and open the program
group that contains the AT&T PassageWay applications. To run AT&TSet, just
double-click on the AT&TSet icon. An untitled AT&TSet file appears, displaying
the current programming of the buttons on your telephone.

The first time you run AT&TSet, the system presents the Telephone Setup
dialog box.

Figure 4-3. Telephone Setup Dialog Box

Select the appropriate option button, and then select the OK button. AT&TSet
then displays the following dialog box:
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Figure 4-4. AT&TSet Dialog Box

Select the OK button. The Reading Telephone dialog box appears, and
AT&TSet reads the programming from your telephone.

Figure 4-5. Reading Telephone Dialog Box
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When AT&TSet finishes reading the programming from your telephone, an
untitled AT&TSet file appears, containing the current programming of your
telephone. Figure 4-6 shows a sample AT&TSet window.

Figure 4-6. Sample AT&TSet Window

Whenever you run AT&TSet, the current programming of your telephone is
displayed. Refer to the following section describing the tasks that you will
perform regularly while using AT&TSet.
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Tasks

This section provides the tasks that you will perform while using AT&TSet.
These tasks are presented in alphabetical order.

NOTE:
The following tasks are performed within the AT&TSet application.

Accessing the Current Programming
from your Telephone

To access the current programming from your telephone, select Read from
Telephone... from the File menu.

NOTE:
If you have made any changes to the AT&TSet file that is currently displayed,
the AT&TSet dialog box appears and prompts you to save your changes.
Select the Yes button if you want to save your changes.

The Reading Telephone dialog box appears, informing you that the system is
reading the programming information from your telephone.
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Figure 4-7. Reading Telephone Dialog Box

When the system is finished reading your telephone, the dialog box
disappears, and the programming information is displayed in a new, untitled
file. You can now modify and save this file.

Changing Button Labels

AT&TSet enables you to change the labels for programmed buttons. However,
changing the label for a button does not affect that button’s programming. To
change a button label:

1. Click on the button label that you want to change.

The button label you selected is highlighted

2. Select Change Button Label... from the Programming menu.

The Change Button Label dialog box appears. 
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Figure 4-8. Change Button Label Dialog Box

3. Modify the label.

4. When you are finished, select the OK button.

The Change Button Label dialog closes, your new button label
information is displayed, and the button position displays "use."
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Converting a File to a Different Button
Configuration

AT&TSet enables you to convert the button configuration in a file to one of the
other two button configurations. AT&TSet supports 10-, 20-, and 28-button
configurations.

To convert the button configuration:

1. Open the AT&TSet file that you want to convert.

2. Select Convert to... from the File menu.

A second menu appears.

3. Perform one of the following steps:

— If you want a 10-button configuration (for an MLX-10DP), select
10 Button.

— If you want a 20-button configuration (for an MLX-20L), select
20 Button.

— If you want a 28-button configuration (for an MLX-28D), select
28 Button.

A warning dialog box appears, prompting you to confirm that you want
to proceed.

NOTE:
If you convert to a configuration with fewer buttons, you cannot
retrieve the button programming for the buttons that are deleted
during the conversion.
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4. Select the Yes button.

AT&TSet displays a new file containing the present programming of your
telephone.

If you have a 28-button telephone and select “20 Button,” AT&TSet
displays a 20-button configuration. The top two rows of buttons from
your 28-button configuration are removed. The remaining buttons
contain the current programming of your telephone for those buttons. If
you have a 28-button telephone and select “10 Button,” AT&TSet
displays a 10-button configuration. The top two rows of buttons and the
two rows of buttons on the right-hand side of the window are removed.
The remaining buttons contain the current programming of your
telephone.

If you have a 20-button telephone and select “28 Button,” AT&TSet
displays 28 buttons, with the first two rows of buttons blank. The
remaining buttons contain the current programming of your telephone. If
you have a 20-button telephone and select “10 Button,” AT&TSet
displays 10 buttons. The two rows of buttons on the right-hand side of
the window are removed. The remaining buttons contain the current
programming of your telephone.

If you have a 10-button telephone and select “20 Button,” AT&TSet
displays 20 buttons. Two columns of blank buttons are added to the
right-hand side of the window. If you have a 10-button telephone and
select “28 Button,” AT&TSet displays 28 buttons. Two columns of blank
buttons are added to the right-hand side of the window, and two rows of
blank buttons are added to the top.
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Creating a New File

You can create and save multiple AT&TSet files on your PC, enabling you to
customize your telephone as often and as much as you like. To create a new
file:

1. Select New from the File menu.

A second menu appears.

2. Perform one of the following steps:

— If you want a 10-button configuration (for an MLX-10DP), select
10 Button.

— If you want a 20-button configuration (for an MLX-20L), select 20
Button.

If you want a 28-button configuration (for an MLX-28D), select 28
Button.

—

NOTE:
If you made any changes to the current AT&TSet file, a dialog
box appears and prompts you to save your changes. Select the
Yes button if you want to save your changes.

AT&TSet displays a new file containing the present programming of your
telephone.

If you have a 28-button telephone and select “20 Button,” AT&TSet
displays a 20-button configuration. The top two rows of buttons from
your 28-button configuration are removed. The remaining buttons
contain the current programming of your telephone for those buttons. If
you have a 28-button telephone and select “10 Button,” AT&TSet
displays a 10-button configuration. The top two rows of buttons and the
two rows of buttons on the right-hand side of the window are removed.
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The remaining buttons contain the current programming of your
telephone.

If you have a 20-button telephone and select “28 Button,” AT&TSet
displays 28 buttons, with the first two rows of buttons blank. The
remaining buttons contain the current programming of your telephone. If
you have a 20-button telephone and select “10 Button,” AT&TSet
displays 10 buttons. The two rows of buttons on the right-hand side of
the window are removed. The remaining buttons contain the current
programming of your telephone.

If you have a 10-button telephone and select “20 Button,” AT&TSet
displays 20 buttons. Two columns of blank buttons are added to the
right-hand side of the window. If you have a 10-button telephone and
select “28 Button,” AT&TSet displays 28 buttons. Two columns of blank
buttons are added to the right-hand side of the window, and two rows of
blank buttons are added to the top.

Exiting AT&TSet

To exit AT&TSet, select Exit from the File menu.

Inspecting a Button

AT&TSet enables you to determine how a button is programmed. To inspect a
button:

1. Click on the button label that interests you:

The button label you selected is highlighted.
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2. Select Inspect Button... from the Programming menu.

The Inspect Feature Button dialog box appears, displaying the following
programming information:

— feature assigned to the button

— button label assigned to the button
— information associated with the button (for example, extension,

telephone number, or group number assigned to the button)

Figure 4-9. Inspect Feature Button Dialog Box

At this point, you may change the label for this button by choosing the
Label button.

3. When you are finished, select the OK button.
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Opening an Existing File

To open an existing file:

1. Select Open... from the File menu.

The Open dialog box appears.

2. Select the file you want to open.

The name of the file appears in the File Name list box.

3. Select the OK button.

The file you selected is displayed.

Printing Button Labels

AT&TSet enables you to print the labels for buttons in an AT&TSet file. You
can print these labels on either a perforated AT&T button label form or a plain
sheet of paper. To print labels:

1. Select Print Labels... from the File menu.

The Print Labels dialog box appears.

Figure 4-10. Print Labels Dialog Box
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2. Select the checkbox of the quadrant where you want the labels printed
on the page. If you select all of the quadrants, AT&TSet will print four
copies of the labels on the page (one copy in each quadrant of the
page).

3. Select whether you want the outline of the buttons printed. If you are
printing the labels on a plain sheet of paper, select the checkbox for
Print form outline. If you are printing the labels on a perforated AT&T
button label form, do not select the checkbox for Print form outline.

4. Select the OK button.

The button labels are printed.
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Programming a Button

AT&TSet enables you to program a new button or change the feature of a
button that has already been programmed in an AT&TSet file. Changing the
programming of a button in an AT&TSet file does not affect the current
programming of your telephone unless you select the button to be used, and
then write the file to your telephone (via the Write to Telephone option in the
File menu).

To program a new button or change the feature of a button that has already
been programmed:

1. Click on the button label that you want to program.

The button label becomes highlighted.

2. Select Change Button Programming... from the Programming
menu.

The Change Button Programming dialog box appears.
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Figure 4-11. Change Button Programming Dialog Box

3. Select the option button of the feature that you want to program to this
telephone button in your AT&TSet file.

4. Select the OK button.

The Program Feature dialog box appears. This dialog box enables you
to use the default button label for this feature or customize the label.
Depending on the feature, this dialog box may prompt you to enter more
information for the feature (for example, an extension). The Feature
Help button provides an on-line help screen for the selected feature.
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5. Perform one of the following steps:

— If you want to use the default button label, select the OK button.

The Program Feature dialog box disappears, and the default
button label appears on the button you selected. The button
position for the button you selected is highlighted and displays
“use,” signifying that the programming for this button will be
applied to your telephone when you write this file to your
telephone. The button label is gray.

— If you want to change the default label, perform the following
steps:

a. Select the Label button.

The Change Button Label dialog box appears.
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b. Enter the label you want, and then select the OK button.

You return to the Program Feature dialog box, and the
new button label is displayed.

c. Select the OK button.

The Program Feature dialog box disappears, and your
custom button label appears on the button you selected.
The button position for the button you selected is
highlighted and displays “use,” signifying that the
programming for this button will be applied to your
telephone when you write this file to your telephone. The
button label is gray.

Programming Your Telephone

The procedure to program your telephone writes to your telephone all of the
button features, Non-Button Ringing features, and Non-Button features that are
selected as “use” in the currently displayed AT&TSet file. This procedure
changes the programming of your telephone.

To program your telephone:

1. Open the file that has the feature(s) you want to program to your
telephone.

The selected file appears. All of the button features, Non-Button Ringing
features, and Non-Button features that display “use” will be programmed
to your telephone.

2. Select Write to Telephone... from the File menu.

The Write to Telephone dialog box is displayed.

4-23



Using AT&TSet

Figure 4-13. Write to Telephone Dialog Box

The selected features are programmed to your telephone.

Saving a File

The procedures for saving a file depend on the following scenarios:

■ saving a new file (that is, one that has not been saved previously and
has the title AT&TSet-(UNTITLED))

■ modifying an existing file and saving it under a new file name

■ saving changes to an existing file (that is, one that has been saved
previously and has a title)

Saving a New File

To save a new file (that is, a file that has the title AT&TSet-(UNTITLED)):

1. Select Save AS... from the File menu.

The Save As dialog box appears.
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2. Enter the name of the file.

The name of the file appears in the File Name list box.

NOTE:
AT&TSet automatically adds the “.set” suffix to the file name you
enter. If you prefer, you may enter another suffix. However, it is
recommended that you use the “.set” default to make it easier to
identify and load AT&TSet files.

3. Select the OK button.

The Save As dialog box closes, and the new title appears at the top of
the window.

Modifying an Existing File and Saving It as a Different File

Many times, you will create new files by modifying existing files. For example,
if you want to change one button in a file while maintaining that original file,
you can open that file, make your changes, and then save the modified file
under a new title. This way, you save time and effort and still have your
original file.

To save an existing file under a new title: 

1. Select Save As... from the File menu.

The Save As dialog box appears.

2. Enter the name of the file.

The name of the file appears in the File Name list box.
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NOTE:
AT&TSet automatically adds the “.set” suffix to the file name you
enter. If you prefer, you may enter another suffix. However, it is
recommended that you use the “.set” default to make it easier to
identify and load AT&TSet files.

3. Select the OK button.

The Save As dialog box closes, and the new title appears at the top of
the window.

Saving Changes to an Existing File

To save changes to an existing file, select Save from the File menu.

Selecting Buttons to be Programmed
to your Telephone

Before you can program a button to your telephone, you must select the button
to be used. To select a button to be used when programming:

1. Click on the button label that you want to write to your telephone.

The button label is highlighted.

2. Select Use Button When Programming from the Programming
menu.

The button position displays "use."

To select all of the buttons to be used when writing the file to your telephone,
select Use All Buttons from the Programming menu.
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Setting Non-Button Features

Non-Button features affect the overall operation of your telephone and are not
associated with specific buttons. AT&TSet enables you to activate or
deactivate the following Non-Button features for your telephone:

■

■

■

■

■

Callback Automatic

Call Waiting

Coverage - Inside

Line Preference

Receive Voice Calls

NOTE:
Line Preference must be activated for the AT&TCall application to
operate properly. Deactivating this feature will adversely affect
AT&TCall.

The settings of the Non-Button features in the file are displayed in the Non-
Button Features and Ringing Status Bar, located at the bottom of the AT&TSet
window.

To activate or deactivate Non-Button features for your telephone:

1. Select Non-Button Features... from the Programming menu.

The Non-Button Features dialog box appears.
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Figure 4-14. Non-Button Features Dialog Box

2. Select the feature(s) you want to activate or deactivate.

A marked checkbox next to a feature indicates that the feature is
activated, while a blank checkbox indicates that the feature is
deactivated.
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3. Select the Use or Skip option buttons to indicate whether you want to
apply the feature when you write this file to your telephone (via the
Write to Telephone option in the File menu). If you select Use, the
feature will be applied when you write this file to your telephone. If you
select Skip, this feature will not be applied when you write this file to
your telephone.

4. When you are finished, select the OK button.

Setting Non-Button Ringing

The Non-Button Ringing options allow you to customize how your telephone
rings. These options are not associated with specific buttons. AT&TSet enables
you to set the following ringing preferences for all of the lines appearing on
your telephone:

■

■

■

abbreviated ringing

personalized ringing

shared system access rings (PBX only)

Using the personalized ringing option, you may select any one of eight ringing
patterns for your telephone. The settings of the Non-Button Ringing options in
the file are displayed in the Non-Button Features and Ringing Status Bar,
located at the bottom of the AT&TSet window.
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NOTE:
The ringing features discussed above are not programmed to buttons; they are
programmed to facilities that are assigned to your telephone by your System
Manager. As a result, you can only set ringing features if you have a facility
assigned to your telephone.

To set ringing preferences for all of the lines appearing on your telephone:

1. Select Non-Button Ringing... from the programming menu.

The Non-Button Ringing Options dialog box appears.
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Figure 4-15. Non-Button Ringing Options Dialog Box

2. Select the ringing preferences you want to activate or deactivate.

A marked checkbox next to the feature indicates that the feature is
activated, while a blank checkbox indicates that the feature is
deactivated. You may select only one Ring option. To set Personalized
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Ringing, select the Personalized Ringing box, and select the number of
rings you want (1 through 8).

3. Select the Use or Skip option buttons to indicate whether you want to
apply the feature when you write this file to your telephone (via the
Write to Telephone option in the File menu). If you select Use, the
feature will be applied when you write this file to your telephone. If you
select Skip, this feature will not be applied when you write this file to
your telephone.

4. When you are finished, select the OK button.

4-32



Using AT&TSet

AT&TSet Menu Bar Options

AT&TSet provides the following options in the menu bar:

■ File

■ Setup

■ Programming

■ Help

This section describes the options contained in each AT&TSet menu.

File

The File menu contains the following options:

■

■

■

■

■

■

■

■

■

■

New

Open...

Save

Save As...

Convert to...

Write to Telephone...

Read from Telephone...

Print Setup...

Print Labels...

Exit
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New

Enables you to create a new AT&TSet file that contains 10, 20, or 28 buttons.
When selected, this option presents the current programming of your
telephone. The window title displays “AT&TSet-[UNTITLED.SET].”

Open...

Enables you to open an existing AT&TSet file. When selected, this option lists
the existing AT&TSet files. You may scroll through the list and select a specific
file.

Save

Saves the changes made to the AT&TSet file on which you are working.

Save As...

Prompts you to name the file on which you are working. The default extension
for every AT&TSet filename is “.set.”

Convert to...

Converts the currently displayed AT&TSet file to a 10, 20, or 28 button
AT&TSet file.

Write to Telephone...

Programs features in your current file to the corresponding buttons on your
telephone. Only the features that are marked “use” will be programmed to the
telephone.
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Read from Telephone...

Accesses and displays the current programming of your telephone.

Print Setup...

Displays the Windows printer setup window, enabling you to modify the printer
settings (for example, printer type).

Print Labels...

Prints the features programmed on the buttons in a format that is consistent
with the set labels.

Exit

Closes the AT&TSet application.
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Setup

The Setup menu contains the Telephone option.

Telephone

Enables you to specify if you are an operator.
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Programming

The Programming menu contains the following options:

■ Inspect Button...

■ Change Button Programming...

■ Change Button Label...
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Use Button When Programming

Instructs the system to program the selected button in the file to the associated
button on the telephone when the Write to Telephone option is selected from
the File menu.

Skip Button When Programming

Instructs the system not to program the selected button in the file to the
associated button on the telephone when the Write to Telephone option is
selected from the File menu.

Use All Buttons

Instructs the system to program all of the buttons in the file to the associated
buttons on the telephone when the Write to Telephone option is selected from
the File menu.

Skip All Buttons

Instructs the system not to program any of the buttons in the file to the
associated buttons on the telephone when the Write to Telephone option is
selected from the File menu.

Non-Button Features...

Enables you to activate or deactivate the following features for your telephone:

■ callback automatic

■ call waiting

■ coverage - inside

■ line preference
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Non-Button Ringing...

Enables you to set the following ringing preferences for all of the lines
appearing on your telephone:

■ abbreviated ringing

■ personalized ringing

■ shared system access rings
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Help

The Help menu contains the following options:

■ Contents

■ Search for Help on...

■ How to Use Help

■ Feature Browser
■ About AT&TSet...

Contents

Displays the topics in on-line Help.

Search for Help on...

Opens the Search dialog box for on-line Help. You can look up Help
information by entering keywords in the dialog box.

How to Use Help

Describes how to use on-line Help.

Feature Browser

Enables you to view information on any button feature.

About AT&TSet...

Displays the AT&TSet version number, the MERLIN LEGEND version number,
and the mode in which the MERLIN LEGEND system is operating.
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5

Overview

This chapter provides the following information:

■ a description of Log Viewer

■ helpful hints when using Log Viewer

■ the procedures for running Log Viewer

■ the tasks you will perform regularly while using Log Viewer

■  a description of all the Log Viewer menu options
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What Is Log Viewer?

Log Viewer is an application that enables you to view entries that are stored in
the PassageWay call log. The call log stores a record entry of every call you
make from the Dial buttons of a card or Quick Dials in an AT&TCall file. The
call log does not store entries of calls you make from your telephone directly or
from the Dialpad window in AT&TCall.

Figure 5-1 shows the Log Viewer window.

Figure 5-1. Log Viewer Window
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The call log can store a maximum of 8,000 entries. When this maximum is
reached, the oldest call entry (that is, entry 1) is overwritten by the newest
entry (that is, entry 8001). Each call log entry consists of the following
components:

■ the primary and secondary labels of the card associated with the call

■ the account code associated with the call
■ the telephone number dialed
■ the date and time the telephone number was dialed

■ the type of call ("O" for outgoing)

Log Viewer enables you to perform the following tasks with the entries in the
call log:

■

■

■

■

■

view selected entries

sort selected items

delete entries

move entries from the log to a permanent archive file

print entries
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Helpful Hints

When using Log Viewer, keep in mind the following information:

■

■

■

When the Log Viewer window is open, select the Refresh option from
the View menu to make sure you are viewing all of the entries you have
specified. If you make a call while the Log Viewer window is open, that
entry will not be displayed in the Log Viewer. The Refresh option
insures that all relevant entries are displayed.

The call log stores a maximum of 8,000 calls. Entry 8001 overwrites the
oldest entry in the call log.

By default, the system automatically adds deleted entries to the call log
archive file. The call log archive is an ASCII file in which each field of
data is separated by a tab. The archive file is called PWLOG.ARC and
is located in your Windows directory. This file can be viewed, edited, or
modified by any program that can access ASCII files. If you do not wish
to keep your call log entries permanently, turn off the “Add auto. deleted
entries to archive file” option from the Preferences option in the Setup
menu.
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Running Log Viewer

To run Log Viewer, you must access Windows and open the program group
that contains the AT&T PassageWay applications. You can run Log Viewer by
itself, or access it from within the AT&TCall application. To run Log Viewer by
itself, double-click on the Log Viewer icon. The Log Viewer window appears.
Refer to the following section describing the tasks that you will perform
regularly while using Log Viewer.
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Tasks

This section describes the tasks that you will use with the Log Viewer. These
tasks are presented in alphabetical order.

Deleting Entries from the Call Log

To delete entries from the call log:

1. Select the entries that you want to delete from the Log Viewer window.
If you want to select all of the entries in the Log Viewer, select Select
All from the Edit menu.

The entries that you selected are highlighted.

2. Perform one the following steps:

— If you want to add these entries to the call log archive file, select
Move to Archive from the Edit menu.

The PassageWay Log Viewer dialog box appears, displaying the
number of entries that will be deleted from the call log.
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Figure 5-2. PassageWay Log Viewer Dialog Box

Select the OK button.

—

The entries are deleted from the log and added to the archive
file.

If you do not want to add these entries to the call log archive file,
select Delete from the Edit menu.

The entries are deleted.
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Printing Log Entries

Log Viewer enables you to print the entries that are displayed in its window. To
print log entries:

1. Using the Filter/Sort Options option from the View menu, view the calls
that you want to print.

The specified calls are displayed in the Log Viewer window.

2. Select Print View from the File menu.

The entries displayed in the Log Viewer window are printed.

Setting the Log Viewer Preferences

You can set Log Viewer to perform the following procedures automatically:

■ delete entries after a specified number of days

■ add automatically deleted entries to the call log archive file

NOTE:
By default, the call log archive keeps a copy of all entries that are
deleted automatically by the program (for example, exceeding the
maximum number of entries or deleting entries after a certain
number of days). These entries will not be added to the call log if
the “Add auto. deleted entries to archive file” option is turned off.

■ display a warning when a specified percentage of the call log is filled
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To set the preferences:

1. Select Preferences... from the Setup Menu

The Preferences dialog box appears.

Figure 5-3. Preferences Dialog Box

2. Select the preferences you want.

3. Select the OK button.
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Sorting Call Log Entries

Log Viewer enables you to specify the criteria for sorting call log entries and
the order in which these sorted entries are displayed. You can sort the
displayed entries according to the following criteria:

■ text label

■ telephone number

■ account number

■ date and time the telephone number was dialed

Sorted entries can be displayed in the order of oldest first or newest first.

To sort entries in the Log Viewer:

1. Select Filter/Sort Options... from the View menu.

The Filter/Sorting Options dialog box appears.

5-10



Using Log Viewer

Figure 5-4. Filter/Sorting Options Dialog Box

2.

3.

4.

Select the option button of the Sort By option you want.

Select the option button of the Order option you want.

Select the OK button.

The Log Viewer displays the call log entries in the order in which you
requested. The top of the window displays the current sorting options.
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Specifying the Calls to be Displayed

Log Viewer enables you to specify which call log entries you want displayed in
the Log Viewer window. You can specify entries according to the following
criteria:

■

■

■

■

text label

telephone number

account number

date

To specify the calls to be displayed:

1. Select Filter/Sort Options... from the View menu.

The Filter/Sorting Options dialog box appears.
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Figure 5-5. Filter/Sorting Options Dialog Box

2. Select the filtering options you want.

3. Select the  OK Button.

Log Viewer displays the calls that you specified. The top of the window
displays the viewing selection.
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Log Viewer Menu Bar Options

Log Viewer provides the following options in the menu bar:

■ File

■ Edit

■ View

■ Setup

■ Help

This section describes the options contained in each Log Viewer menu.
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File

The File menu contains the following options:

■ Print View

■ Print Setup...

■ Exit

Print View

Prints the entries that meet the criteria you specified.

Print Setup...

Displays the Windows printer setup window, allowing you to modify the printer
settings (for example, paper size and orientation).

Exit

Exits the Log Viewer application.
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Edit

The Edit menu contains the following options:

■ Copy

■ Delete

■ Move to Archive

■ Select All

Copy

Copies the currently selected information from the Log Viewer window and
places it in the Windows Clipboard.

Delete

Deletes the currently selected information from the Log Viewer window. Once
deleted, this information is no longer present in the call log.

Move to Archive

Deletes the currently selected information from the Log Viewer window and
adds it to the call log archive file.

Select All

Selects all of the entries currently displayed in the Log Viewer window.
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View

The View menu contains the following options:

■ Filter/Sort Options...

■ Refresh

■ Hide Account Field

Filter/Sort Options...

Enables you to specify which calls you want displayed in the Log Viewer (that
is, filter), and the order in which you want the calls displayed (that is, sort).

Refresh

Updates the information displayed in the Log Viewer.

Hide Account Field

Enables you to either show or hide the account codes associated with the calls
displayed in the Log Viewer. A check next to this option indicates that the
account codes will not be displayed for each call.
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Setup

The Setup menu contains the Preferences option.

Preferences...

Enables you set Log Viewer to perform the following procedures automatically:

■ delete entries after a specified number of days

■ add automatially deleted entries to an archive file

■ display a warning when a specified percentage of the call log is filled

Help

The Help menu contains the following options:

■ Contents

■ Search for Help on...

■ How to Use Help

■ About PassageWay Log Viewer...

Contents

Enables you to access the on-line help for Log Viewer.

Search for Help on...

Enables you to access help information on a certain topic.
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How to Use Help

Describes how to use the on-line help for Log Viewer.

About PassageWay Log Viewer

Displays the number of entries currently in the view (that is, the number of
entries that meet the criteria you specified), the capacity of the call log, and the
number of entries in the call log.
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6

Overview

This chapter provides the following information:

■ a description of AT&TConnect

■ how to access AT&TConnect

■ tasks you may have to perform

NOTE:

■ a description of all the AT&TConnect menu options

You should only access AT&TConnect if there are communication problems
between your PC and your MLX telephone.
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What Is AT&TConnect?

AT&TConnect is the manager for all the PassageWay applications. Even when
a user is not using a PassageWay application, but is using the adapter in
Autodial mode (or “Hayes” mode), the AT&TConnect software ensures correct
operation of the serial port.

Every time you invoke Windows, AT&TConnect is automatically loaded (unless
you removed the AT&TConnect icon from your Startup group), and its icon
appears at the bottom of your screen. If you did not specify a valid COM port
when you installed the PassageWay software, the system will prompt you for a
COM port when you invoke AT&TConnect. After you specify the COM port,
AT&TConnect retains this information and does not prompt you for it again.

Once AT&TConnect has a valid COM port, the software attempts to
communicate with the adapter. If AT&TConnect is unable to communicate with
the adapter, the system displays a troubleshooting window. When
AT&TConnect successfully communicates with the adapter, the AT&TConnect
icon appears at the bottom of your screen.

Running AT&TConnect

If AT&TConnect is in your Startup group, the AT&TConnect icon is displayed
automatically at the bottom of your screen when you access Windows. To run
AT&TConnect manually, you must first access Windows and open the program
group that contains the PassageWay applications. To access AT&TConnect,
double-click on the AT&TConnect icon at the bottom of your screen. The
AT&TConnect window appears.
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Figure 6-1. AT&TConnect Window
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Tasks

This section provides tasks that you may have to perform while using the
PassageWay applications. These tasks are presented in alphabetical order.

Accessing the Events Log

If you are having problems with PassageWay and receive support from AT&T,
you may be asked to access the Events Log. The Events Log records certain
events for information purposes only and is used for diagnosing a problem.

To access the Events Log:

1. Select Events Log... from the Setup menu.

The Events dialog box appears.
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Figure 6-2. Events Log Dialog Box

2. When finished, select the OK button.
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Changing the COM Port

If for some reason you connect PassageWay to a different COM port, perform
the following steps:

NOTE:
You cannot select a new COM port for PassageWay while
PassageWay applications other than AT&TConnect are running.

1. Select COM Port... from the Setup menu.

The COM Port Dialog Box appears.

Figure 6-3. COM Port Dialog Box
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2. Select the option button of the COM port to which you connected the
PassageWay adapter, and then select the OK button.

Changing the System Configuration
Information

You must update the system configuration information if one or more of the
following actions occurs:

■ you have a different telephone type

■ your MERLIN LEGEND system has been upgraded
■ the mode of your MERLIN LEGEND system has been changed

NOTE:
You cannot change the System Configuration information while
PassageWay applications other than AT&TConnect are running

To update the system configuration information:

1. Select Configure System... from the Setup menu.

The Configure System dialog box appears.
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Figure 6-4. Configure System Dialog Box

2. Update the appropriate information, and then select the OK button.

Testing the PassageWay Adapter

If you are having problems with PassageWay, perform the following steps:

 NOTE:
You cannot test the PassageWay adapter while PassageWay
applications other than AT&TConnect are running.

1. Select Test Adapter from the Setup menu.

The Test Adapter dialog box appears.
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Figure 6-5. Test Adapter Dialog Box

2.

3.

4.

Select the OK button.

The PassageWay Test-In Progress dialog box appears, and instructs
you to examine the LED located on the PassageWay adapter.

Examine the LED on the PassageWay adapter, and then select the
appropriate button in the dialog box.

The PassageWay Test-Completed dialog box appears, displaying the
results of the test.

NOTE:
If the PassageWay Test fails, refer to Chapter 8.

Select the OK button.
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AT&TConnect Menu Bar Options

AT&TConnect provides the following options in the menu bar:

■ File

■ Setup

■ Help

This section describes the options contained in the AT&TConnect menus.

File

The File menu contains the Exit option.

Exit

Exits the AT&TConnect software.
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Setup

The Setup menu contains the following options:

■ COM Port...

■ Configure System...

■ Test Adapter

■ Events Log...

COM Port...

Enables you to select the COM port for your PassageWay adapter.

Configure System...

Enables you to modify the system configuration information.

Test Adapter

Activates a self-test of the PassageWay adapter.

Events Log...

Records certain events for information purposes only and is used for
diagnosing a problem.
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Help

The Help menu bar option contains the following options:

■ Contents

■ Search for Help On

■ How to use Help

■ About AT&TConnect...

Contents

Enables you to access the on-line help for AT&TConnect.

Search for Help On

Enables you to access Help information on a cetain topic.

How to use Help

Describes how to use the on-line help for AT&TConnect.

About AT&TConnect...

Displays the AT&TConnect version number, the PassageWay API DLL version
number, and the number of PassageWay applications that are currently active.
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Using Autodialing Applications
with PassageWay 7

Overview

This chapter provides information for using other Windows applications with
PassageWay. Most applications that are designed to autodial (using the
Hayes’ command set) can work with PassageWay.

Using Autodialing Applications

Windows applications such as personal information managers (PIMs),
schedulers, and the Windows Cardfile dial phone numbers via modems using
the Hayes’ command set. They do not use the modem to transfer data; rather,
they dial the phone number you select and expect you, the user, to pick up the
telephone to complete the call.

PassageWay can decode the Hayes’ commands necessary to dial a telephone
number. The application that performs the dialing will think there is a modem
connected to your PC, not PassageWay. There are a few parameters and
guidelines that need to be followed to ensure that PassageWay will operate
with your application.
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Modems communicate back to the PC, sending messages such as “OK” and
“Error.” Most autodialing applications do not look for the modem to respond.
There are some autodialing application programs that rely on the modem
feedback. PassageWay does not provide feedback, and the applications that
require it will not operate with PassageWay.

Setting Up PassageWay

To use PassageWay with autodialing applications, the AT&TConnect
application must be running while the autodialing application is running.

NOTE:
Other PassageWay applications (such as AT&TCall and
AT&TSet) cannot be running while PassageWay is being used by
autodialing applications.

Also, when PassageWay applications are running, you cannot
use autodialing applications.

7-2



Using Autodialing Applications with PassageWay

Setting Up Your Application

Set the following parameters for your application:

■ Baud Rate

PassageWay requires that the application use 1200 baud.

COM Port■

Make sure you select the same COM port that is connected to
PassageWay.

Data bits■

The data bits (Word length) should be set to 7 or 8.

Tone or Pulse dialing■

Either setting will work with PassageWay.

■ Prefix/Suffix

Whatever number you select for the application to use for a dialing
prefix and/or suffix will be used by PassageWay.

NOTE:
Stop bits and parity are not important to PassageWay.
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Helpful Hints

Keep in mind the following information when using PassageWay with
autodialing applications:

■

■

Make sure all phone numbers you use are appropriate for using with
your MERLIN LEGEND system. For example, if you normally dial “9,”
then put a “9” either in the phone number, or in as a prefix (if your
application has this capability).

Don’t continue your application until the call is completely dialed. Many
applications have a dialog box with a message such as “Pick up Phone:
OK.” This hangs up the modem. When using PassageWay, selecting
the OK button will stop PassageWay from dialing, but will not hang up
your MLX telephone.
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8

Overview

This chapter provides information that can assist you in solving problems that
you might encounter with PassageWay. This chapter is divided into the
following sections:

■ “Troubleshooting AT&TConnect”

■ “Troubleshooting AT&TCall”

■ “Troubleshooting AT&TSet”

Refer to the appropriate section to find the information required to solve your
particular problem. Also, you may want to refer back to the chapters discussing
the PassageWay applications to resolve problems that might arise due to
confusion about how a particular feature works. Keep in mind that AT&TCall
and AT&TSet depend on AT&TConnect in order to communicate with your
telephone. As a result, problems with AT&TCall and AT&TSet may actually be
caused by a problem with AT&TConnect.
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Troubleshooting AT&TConnect

This section presents some common problems that you might encounter while
using AT&TConnect. For each problem, a strategy is presented that you can
follow to isolate and solve your problem.

Problem 1: AT&TConnect will not run. It displays the message
This application requires a serial port and terminates.

This message indicates that AT&TConnect cannot find an available serial port
on your system. This message will most likely appear immediately after you
have completed the installation of the PassageWay software using the setup
program since this is the first time AT&TConnect tries to run.

If you do not have an available serial port (for example, if you have only one
serial port, and this port is being used by your mouse), you will need to add an
additional serial port to your PC in order to use PassageWay. Your computer
vendor can assist you in obtaining the necessary hardware to add another
serial port. See Appendix B for more information.

If you are certain that you have an available serial port (other than a port being
used by your mouse), the available port might be disabled, in which case
AT&TConnect will be unable to detect its presence. You can verify the number
of active serial ports in your system using the following procedure:

1. Exit Windows and return to DOS.

The DOS prompt appears.

2. Access the directory in which PassageWay resides.
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3. Type comcheck and press [ ENTER ↵ ].

The status of each COM port in your PC is displayed. The following is a
sample of what you may see:

COMCheck V1.0 (c) 1993 AT&T
Serial port detection program

Port Detected
---- ---------
COM1 Yes
COM2 Yes
COM3 No
COM4 No

If this procedure reveals that your PC has no active COM ports or only COM1
is active (but is used by your mouse under Windows), you will need to either
purchase an additional COM port for your PC or consult your PC’s hardware
documentation to determine how to re-enable a COM port that might be
disabled. (Refer to Appendix B for information on COM ports.) Re-enabling a
COM port may require changing the placement of a jumper on your computer’s
system board or running your PC’s setup program.
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Problem 2: AT&TConnect displays its Communications Error dialog box
within a few seconds after it is run

This message indicates that AT&TConnect cannot communicate properly with
your PassageWay adapter. This message can appear for one of the following
reasons:

■

■

■

■

Your PassageWay adapter is not connected properly to your PC serial
port and/or your MLX telephone.

Your MERLIN LEGEND system wiring does not support the remote
powering of adjuncts such as PassageWay.

AT&TConnect is administered to use a different serial port than the one
to which the PassageWay adapter is connected.

One or more cables and/or adapters is damaged or not compatible with
PassageWay.
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Figure 8-1. Communications Error Dialog Box
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You should follow the instructions provided on this dialog box to
troubleshoot the problem. These instructions ask you to verify the
following items:

■ The PC-side and phone-side cabling associated with your PassageWay
adapter is properly connected.

Insure that the 4-foot keyed phone cord is completely inserted into both
the jack marked “DSS” or “Adjunct” of your MLX telephone and the
modular jack on the PassageWay adapter. A proper connection is
confirmed by a tactile “click” as the cord is fully inserted.

Also insure that any RS-232 cables and adapters that you might be
using to connect the PassageWay adapter to your PC should NOT be
null modem cables (a special type of cable), and the total length of the
combined RS-232 cabling should not exceed about 40 feet (the length
should be as short as is convenient for your setup).

■ Insure your PassageWay adapter is receiving power from the MERLIN
LEGEND system (as indicated by the illumination of the power LED).

If you have verified that the PassageWay adapter is properly connected
to your telephone, yet the power LED next to the modular jack on the
adapter is NOT illuminated, your telephone system wiring may not
support the remote powering of adjuncts. If this is the case, you should
consult your AT&T account representative or authorized dealer to obtain
the proper wall supply to power your PassageWay adapter or to correct
any wiring problems which may be the cause.

■ Your COM port administration for AT&TConnect corresponds to the
serial port to which the PassageWay adapter is connected.

Under Windows, AT&TConnect considers any active serial port that is
not being used by a serial mouse to be “available” for use with
PassageWay. Consequently, AT&TConnect will allow you to select a
COM port that could be different from the one to which your
PassageWay adapter is attached. For example, if your PC contains an
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internal fax/modem card, that fax/modem will be using one of your PC’s
COM ports, and you could erroneously administer AT&TConnect to use
this same COM port. When selecting a serial port for AT&TConnect to
use, you should be careful that the COM port you select is not already
being used by another device in your PC.

■ AT&TConnect’s software-based adapter test passes.

To assist you in diagnosing problems, AT&TConnect contains a built-in
adapter test procedure. This test can be run directly from the
Communications Error dialog box by choosing the Test button.

If the test procedure concludes successfully, AT&TConnect is
communicating properly with your PassageWay adapter over the COM
port you selected, and you should select the Connect button on the
Communications Error dialog box to restore normal operation.

If, however, the test fails, an error number will be provided. Use the
following table to interpret the error numbers and to find suggestions for
how to resolve the particular error you encountered.
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Failure Code Meaning Things to Try

111 The PC and the Make sure you have
PassageWay selected the proper
adapter cannot COM port in
communicate over AT&TConnect.
your serial port.

Try replacing any
RS-232 cables or
adapters you are
using between your
PC’s COM port and
the PassageWay
adapter’s 25-pin
connector.

121 The PC and the Follow the
PassageWay instructions for
adapter cannot failure code 111.
communicate over
your serial port.

131, 132, 133, or The PC cannot Try replacing any
135 communicate RS-232 cables or

properly with your adapters you are
PassageWay using between your
adapter. PC’s COM port and

the PassageWay
adapter’s 25-pin
connector.
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134 or 141 The PassageWay Try replacing the 4-
adapter cannot foot keyed
communicate telephone cable
properly with your between the
telephone. PassageWay

adapter and your
telephone.

200 and above A conflict or Try closing all
application error has Windows
occurred which applications except
prevented AT&TConnect and
AT&TConnect from Program Manager,
operating your PC then try the test
serial port. again.

You may need to
modify your
“autoexec.bat” and
“config.sys” files to
eliminate this
conflict.

Problem 3: AT&TConnect will not work on COM3 or COM4

By default, many PCs are not configured to permit the simultaneous use of
three or more COM ports. Specifically, most PCs are configured such that
COM ports are grouped into pairs: COM1 is paired with COM3, and COM2 is
paired with COM4. By default, such PCs permit only one COM port from each
pair to be operating at the same time (for example, COM1 with COM2). COM
ports within the same pair will usually conflict with one another and are not
supported (that is, COM1 with COM3, or COM2 with COM4).
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If you cannot get AT&TConnect to work properly on COM3, check if another
device is using COM1 at the same time. Similarly, if you cannot get
AT&TConnect to work on COM4, determine if another device is using COM2 at
the same time. If so, you may need to make some changes to your PC
configuration to support using PassageWay on COM3 or COM4. Refer to
Appendix B for more information. If you need additional assistance in setting
up devices on COM3 or COM4, consult your PC hardware vendor.

Problem 4: AT&TConnect repeatedly displays its initialization window
(that is, the pop-up window containing the message “AT&TConnect is
intializing your telephone....”) whenever a single PassageWay application
(for example, AT&TCall or AT&TSet) is executed

Close all PassageWay applications (except AT&TConnect), and verify that the
telephone model specified in the “Configure System” option under the “Setup”
menu matches the model of your MLX telephone (i.e., MLX-10DP, MLX-20L,
or MLX-28D). If the incorrect telephone model is specified, AT&TConnect may
not be able to initialize your telephone correctly. The model of your telephone
appears on the phone’s housing near the upper right-hand corner (above the
LCD display).

Problem 5: AT&TConnect occasionally displays its initialization window
while one or more PassageWay applications are running

AT&TConnect displays its initialization window whenever it establishes (or re-
establishes) communication with the PassageWay adapter. Generally, this
window is only displayed once, at the time when a single PassageWay
application is first executed. However, if a communications problem occurs at
any time, AT&TConnect attempts to clear the problem by reinitializing the
adapter, which causes the initialization window to temporarily reappear. If this
occurs while a PassageWay application is performing a task involving the
telephone (for example, while AT&TSet is reading your telephone’s
programming), the operation in progress will be aborted and must be restarted
manually once the initialization window disappears. If no task involving the
telephone is in progress during this process, the Operation of PassageWay
applications is unaffected.
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The likelihood of a communications problem strongly depends on your PC’s
configuration. PassageWay operates at a relatively high data rate (19.2 kbps,
or 19200 baud), and it relies on Windows to manage the flow of data through
your PC’s serial port. Depending upon the speed of your PC, the number and
type of applications you are using, and various hardware components in your
PC configuration, Windows will be able to manage serial communications with
varying degrees of effectiveness.

If you encounter frequent communications errors using PassageWay, your
PC’s current hardware configuration may not support reliable high-speed
communications under Windows. Appendix B includes information about
choosing serial port hardware that can work reliably at high speeds under
Windows.
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Troubleshooting AT&TCall

This section presents some common problems you might encounter using
AT&TCall. For each problem, a strategy is presented that you can follow to
isolate and solve your problem.

Problem 1: AT&TCall does not dial or turn on the speaker

AT&TConnect must be running in order for AT&TCall to dial using your
telephone. Run AT&TConnect, wait for your telephone to be initialized, and try
dialing again.

If AT&TConnect will not run (that is, it displays the message “This application
requires a serial port” and then terminates) or if a communications error occurs
(that is, the Communications Error dialog box appears), refer to
“Troubleshooting AT&TConnect.”

Problem 2: AT&TCall dials the wrong numbers

If AT&TCall dials telephone numbers incorrectly, perform the following steps to
isolate the problem:

1. Create a new card with a simple telephone number such as “777.”

2. Add this card to the card bank.

3. Press the Dial button next to the telephone number and observe the
LCD display of your MLX telephone. The MERLIN LEGEND system will
display each digit dialed by PassageWay on the telephone’s display.
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4.

5.

If the number dialed includes extra unexpected digits either before or
after the number, you probably have a dialing prefix and/or suffix
enabled for all cards in this bank. To disable an unwanted prefix or
suffix, select Dial Options from the Setup menu and select the
checkboxes to disable the prefix or suffix. Remember that prefixes and
suffixes apply to every number on every card in a given bank, so do not
make changes to them unless you wish these changes to apply to all of
the cards in the active bank.

If the number displayed on the screen did not have any extra digits
displayed before or after it, yet the call did not complete, or you reached
an incorrect number, your telephone may not be automatically selecting
the proper line or System Access button. In this case, consult with your
MERLIN LEGEND System Manager and review the information in
Chapter 2 to insure that your telephone is set up correctly.

Problem 3: AT&TCall will not allow you to create a new card or edit an
existing card

Both the New Card and Edit Card buttons are disabled (as are a number of
menu items) whenever you are in the process of creating a new card or editing
an existing one. To restore the capabilities of these buttons, you must
complete the adding/editing operating already in progress and return the
new/edited card to the current card bank.

Note that the New Card and Edit Card windows can be minimized, so it is
possible that you may have minimized one of these windows previously and
have forgotten that you did so. If one of these windows was minimized, its icon
will appear in the icon area near the bottom of your Windows desktop. Simply
double-click on the icon to restore it to a window, then complete the add or
edit operation by choosing Add Card or Return Card. The New Card and Edit
Card buttons will then be restored.
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Troubleshooting AT&TSet

This section describes some common problems you might encounter while
using AT&TSet. For each problem, a strategy is presented that you can follow
to isolate and solve your problem.

Problem 1: AT&TSet does not permit you to program or read your
telephone

AT&TConnect must be running in order for AT&TSet to program and/or read
your telephone. If these options are disabled under the File menu, run
AT&TConnect. After your telephone has been initialized, these options will
become available to you.

If AT&TConnect will not run (that is, it displays the message “This application
requires a serial port” and then terminates), or if a communications error
occurs (that is, the Communications Error dialog box appears), refer to
“Troubleshooting AT&TConnect.”

Problem 2: AT&TSet displays an error message after reading your
telephone

In order to read the information properly from your MLX telephone, AT&TSet
must know the correct release number and mode of your MERLIN LEGEND
system. If either of these parameters is incorrect, AT&TSet will not be able to
read your telephone properly. To change these values, perform the following
steps:

1. Close AT&TSet and AT&TCall (if it is running). Also, if you have any
third party PassageWay applications running (that is, those written by
vendors other than AT&T), close them as well. Leave AT&TConnect
running.

8-14



Troubleshooting

2. Double-click on the AT&TConnect icon to display its window, then select
Configure System. . . from AT&TConnect's Setup menu. Note that
all PassageWay applications (other than AT&TConnect) must be closed
in order to select this option. If any applications are still running, this
option will be disabled.

3. Consulting the System Manager of your MERLIN LEGEND system if
necessary, verify that the settings in this dialog box are correct for your
MERLIN LEGEND system.

4. Run AT&TSet again. If AT&TSet failed to read your telephone’s
programming the first time it was run, it will automatically try to read it
now. If this happens, select the Cancel button on the status dialog box
that appears during the reading process, and select the OK button on
the message box indicating that the read operation was aborted by the
user.

5. Select Telephone. . . from AT&TSet's Setup menu. Consulting the
System Manager of your MERLIN LEGEND if necessary, verify that the
settings in this dialog box are correct for your telephone. In particular,
certain extensions on a given MERLIN LEGEND system are designated
as “operators” even if the people using these extensions do not serve
as operators on the system. AT&TSet needs to know if your extension is
one of these operator positions in order to read your telephone’s
programming properly. The System Manager should be able to tell you
if your extension is one of your system’s operator positions.

6. Select Read from Telephone from AT&TSet’s File menu, and try to
read your telephone’s programming again. If an error message appears
after the reading operation is complete, try choosing the option from the
Telephone dialog box in the previous step (for example, if you originally
had “no” selected, try selecting “yes”) and try again.
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Problem 3: AT&TSet gives you an error message while programming
your telephone (Attempt to replace feature X with feature Y
failed. . .)

This error occurs whenever AT&TSet attempts to program a particular feature
and the MERLIN LEGEND system does not permit the operation to take place.
Generally, AT&TSet knows which operation the MERLIN LEGEND system will
permit and which it will not, and you will generally not be able to select invalid
features for a given button. However, if your telephone’s programming has
been changed by any other means than using AT&TSet, it is possible that
AT&TSet’s image of your telephone’s programming has become outdated, and
operations which AT&TSet thinks are permissible based on its outdated image
may not be permissible when attempted on the telephone. For example, if your
System Manager may have added an extra line appearance to your telephone
using the MERLIN LEGEND system’s centralized programming capabilities.

If this error occurs, you may continue programming your telephone or cancel
the programming operation altogether. In most cases, the safest thing to do is
to cancel the operation and then select Read from Telephone from the File
menu. This operation will refresh AT&TSet’s image of your telephone, which
should prevent programming problems in the future.
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A
This appendix contains the menu trees for the PassageWay applications.
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Figure A-1. AT&TCall Menu Tree
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Figure A-2. AT&TSet Menu Tree

A-3



Menu Trees

Figure A-3. Log Viewer Menu Tree
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Figure A-4. AT&TConnect Menu Tree
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B

Overview

This appendix provides detailed information about PC serial ports, including
background information about what they are and how they work, how Microsoft
Windows 3.1 manages them, how to resolve problems using COM3 or COM4
under Windows, and how to choose serial port hardware that is well-suited to
PassageWay. If you are familiar with serial port terminology (for example, I/O
port addresses, IRQs, etc.), you may wish to skip over the background section.
If not, you should review the background section before reading further.

If you are having problems using PassageWay on COM3 or COM4, you should
refer to “Workarounds and Solutions to the IRQ Conflict Problem” for advice on
solutions and workarounds. If you intend to purchase an add-on serial port
card for use with PassageWay, you should refer to “Selecting an Add-In Serial
Port Card” for information that can assist you in selecting a card.
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Background

Serial ports (also sometimes referred to as communications ports or COM
ports) are hardware interfaces which permit your PC’s microprocessor to
communicate with peripheral devices using a communications standard called
RS-232 (hence, serial ports are also sometimes referred to as RS-232 ports).
Many common computer accessories make use of serial ports, including serial
mice, modems, serial printers, and the PassageWay adapter.

Under DOS (and Windows, which works cooperatively with DOS), the serial
port interfaces in a PC are uniquely identified by specific device names:
COM1 (“serial communications port 1”), COM2 (“serial communications port
2”), and so on, usually up through COM4. A particular PC might have none of
these devices, some of them, or all of them installed. For example, most PCs
currently on the market arrive from the manufacturer with two serial ports
already installed (COM1 and COM2), often integrated onto the computer’s
main system board. Installing additional serial ports (for example, COM3 or
COM4) is usually accomplished by purchasing an add-on card and installing it
into a free expansion slot.

For most purposes (for example, configuring software), the generic description
of serial ports provided by their device names is sufficient. For example,
during the PassageWay installation procedure, you are asked to provide the
device name of the serial port to which you have connected the PassageWay
adapter (for example, COM2). Unfortunately, this abstract view of serial ports
is not sufficient for other purposes, notably for troubleshooting problems: to be
able to do this effectively, a basic understanding of serial port hardware is
required. In particular, it’s essential to understand the mechanics by which the
computer’s microprocessor communicates with serial port hardware.

The microprocessor/serial port communication consists of two aspects: an I/O
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which is used to pass data back and forth to the serial port. This memory
region acts something like a mailbox: outgoing mail (data from the
microprocessor to be transmitted to the peripheral device) is placed in the
mailbox by the owner (the microprocessor) to be picked up by the mail carrier
(the serial port hardware) for subsequent delivery to the destination party (the
peripheral device). In turn, the mail carrier (the serial port hardware) places
incoming mail (data from the peripheral device) into the box to be picked up by
the owner (the microprocessor). This analogy illustrates an additional
important point about I/O port addresses: just as individual mailboxes help the
residents in a neighborhood keep their mail from getting mixed up, each device
using an I/O port address to communicate with the microprocessor should
have a unique address that doesn’t conflict with that of any other device.

The mailbox analogy is also helpful in understanding the IRQ mechanism.
Normally, we place our outgoing mail in our mailbox at any convenient time
before the mail carrier arrives to pick it up. The outgoing mail sits in our
mailbox until the mail carrier arrives, at which time it is picked up and possibly
some incoming mail is placed in the mailbox. Then, some time later, we check
our mailbox and retrieve our new incoming mail. The problem with this
scheme is that it’s not very efficient both the outgoing and incoming mail
spends some time just sitting in the mailbox. A better approach would be if the
mail carrier provided some sort of signal (for example, ringing the doorbell) to
announce his or her arrival, in which case we could hand over the outgoing
mail and pick up the incoming mail immediately. In the PC architecture, IRQs
acts like the doorbell in our analogy: they provide a method by which
hardware devices in the computer can get the microprocessor’s attention to
efficiently deal with some process. The serial port hardware makes use of an
IRQ to announce that it’s ready to receive more outgoing data and/or that new
data has arrived from the peripheral device which needs to be processed.

Like I/O port addresses, IRQs must generally be unique among the active
hardware devices in a computer system. In the mailbox analogy, the doorbell
is probably not a good signal since virtually anyone could ring the doorbell for
any number of reasons, not just to indicate the arrival of mail. Similarly, if a
particular IRQ signal is used (PCs generally support 16 unique IRQ signals,
denoted IRQ0, IRQ1, and so on, up through IRQ15), the microprocessor must
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take the appropriate action for the device associated with that IRQ. If there is
a mix-up, or if more than one device attempts to use the same IRQ at the
same time, a conflict occurs, and the outcome is often unpredictable and
usually undesirable (for example, the computer may “hang”). Because IRQs
are a limited resource, some newer PCs support IRQ sharing, a hardware
mechanism which permits more than one device to make use of the same
IRQ, but most PCs do not. For example, all PCs which use IBM’s
MicroChannel Architecture (MCA) support IRQ sharing, as do most PCs which
use the Enhanced Industry Standard Architecture (EISA) design. However,
most PCs in the marketplace – even new models – are based on the
traditional Industry Standard Architecture (ISA) which generally does not
support IRQ sharing.

The specific I/O port address and IRQ that a particular serial port uses is
determined by the hardware configuration of the serial port. Generally, these
parameters cannot be changed for built-in serial ports, but add-on cards
containing serial ports often provide jumpers or switches which can be used to
configure them to use one of several I/O port addresses and IRQ
combinations. The table below lists the default I/O port addresses and IRQs
used by the serial ports of IBM PC/AT-compatible computers:

Serial Port I/O Port Address IRQ
Device Name

COM1 03F8 4

COM2 02F8 3

COM3 03E8 4

COM4  02E8 3

The values in this table play an important part in understanding the “wrinkles”
associated with serial ports: although there is provision for up to four serial
ports, with four unique I/O addresses, there are only two unique IRQs
associated with them (recall that most PCs require the IRQs used by each
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active device to be unique to avoid conflicts). To understand why, it’s useful
to recall what the PC world was like before the widespread availability of
products like Windows. When the architecture of the current generation of
PCs was first being designed (for the IBM PC/AT), the concept of multitasking
was not nearly as important in the PC marketplace as it is today.
Consequently, since DOS (before Windows) did not permit multiple
applications to run simultaneously (with the notable exception of certain
specialized programs such as mouse drivers), there was little need to provide
a mechanism by which several serial ports could be operated simultaneously.
Consequently, the strategy used was to conserve IRQs by assigning the same
IRQ to more than one COM port (that is, the COM1 and COM3 ports were
both assigned to IRQ4, and the COM2 and COM4 ports were both assigned to
IRQ3). Then, under the assumption that at most two serial ports would be
active simultaneously (for example, COM1 and COM2, which have unique
IRQs), conflicts would not occur.
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Serial Ports Under Windows 3.1

Unlike the DOS-only world of yesterday, today’s multitasking environments like
Windows permit the microprocessor to communicate with up to four active
serial port devices at the same time (COM1 through COM4). For example,
under Windows, if you are using a serial mouse (on COM1) within a terminal
emulator program which operates a data modem (on COM2), while using a fax
board (on COM3) to transmit or receive a fax “in the background,” you are
using three serial port devices simultaneously. You might even wish to make a
phone call using PassageWay (on COM4) at the same time, bringing the total
up to four simultaneously active serial port devices.

The fact that Windows permits this kind of powerful multitasking does not
guarantee that the underlying PC hardware can support this level of operation,
at least without some customizing at the hardware level. Since some PCs can
support it by default (for example, those which support IRQ sharing), Windows
doesn’t prohibit you from configuring your system and attempting tasks like the
one in the previous paragraph. Unfortunately, most PCs cannot support this
operation by default, and the most likely result of attempting the above
scenario is “hanging” the PC due to an IRQ conflict. On such systems, using
COM1 along with COM2 is generally fine (recall that these devices have
unique IRQs by default), but the addition of COM3 or COM4 causes the
system to fail.

Fortunately, Windows 3.1 permits complete customization of all parameters
involving serial ports through the Control Panel, including configuring
nonstandard I/O port addresses and IRQs (that is, values different from those
in the table – these parameters can be viewed and/or modified by selecting
the desired port in the Control Panel’s “Ports” applet, selecting the “Settings...”
button, then selecting the “Advanced...” button). This flexibility offers the
opportunity of salvation for owners of PCs which do not support IRQ sharing
who require the use of three or more COM ports simultaneously.
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Workarounds and Solutions to the
IRQ Conflict Problem

It is important to remember that the IRQ conflict is a problem in hardware; it
cannot be resolved in software alone. Consequently, there are only three
alternatives for working around or resolving it:

Workaround 1: Configure your serial devices such that you use only two
at any one time, and those two use serial ports with unique IRQs.

This is the simplest workaround to the IRQ conflict problem, but it does not
solve the underlying conflict. The idea is to assign your peripheral devices to
your available serial ports in such a way as to avoid using any devices
simultaneously which might conflict. For example, if you have a serial mouse
on COM1 (IRQ4), a fax/modem card on COM2 (IRQ3), and your PassageWay
adapter on COM3 (IRQ4), you cannot effectively use PassageWay since you
need to use your mouse under Windows while PassageWay applications are
running.

A better arrangement would be to move PassageWay to COM4 (IRQ3), which
could then be safely used with your mouse on COM1 (IRQ4). In this case, the
workaround is to avoid trying to use PassageWay at the same time you use
the fax/modem on COM2, since the conflict now would be over IRQ3 (COM2
and COM4).

Workaround 2: Replace one or more of your serial peripherals with
equivalent devices which do not require a serial port.

The idea with this approach is to eliminate the conflict by reducing the number
of peripherals in your system which require serial ports. For example,
replacing a serial mouse with a bus mouse (that is, a mouse which requires its
own add-in card) would make another serial port available that could then be
used by another device.
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Given the scenario described in item (1) above (that is, a mouse on COM1, a
fax/modem card on COM2, and PassageWay on COM3), you might buy a bus
mouse and configure it to use, say, IRQ2 or IRQ5. This would then permit you
to move PassageWay onto COM1 (IRQ4), where it could then be used
simultaneously with both the mouse and the fax/modem.

Likely candidates for conversion from a serial interface to some other interface
include mice (which can be converted to bus mice) and serial printers (which
can be converted to an additional parallel printer port).

Workaround 3: If your serial port hardware permits you to select IRQs
other than the default ones (IRQ3 and IRQ4), make use of one or more
unused IRQs in your system to assign each COM port a unique IRQ.

This solution is generally not possible for built-in serial ports since these are
usually “hard wired” and cannot be changed. Although most add-in cards
containing serial ports permit you to change the IRQs assigned to them, many
cards do not let you select IRQs other than IRQ3 and IRQ4. For example, an
internal modem card generally has jumpers or switches which permit you to
administer the serial interface on the card to be COM1, COM2, COM3, or
COM4, but the I/O port addresses and IRQs associated with each of these
configurations is usually fixed to the settings in the table.

Fortunately, some serial port add-in cards do permit you to select IRQs other
than 3 or 4 (the additional choices are often IRQ2 and IRQ5). If your serial
port hardware provides this flexibility – and at least one of the IRQ numbers
available as an option is currently unused in your PC setup – you can solve
the IRQ conflict directly.

For example, consider once again the scenario of a COM1 mouse, a COM2
fax/modem card, and a COM3 PassageWay. If the COM3 serial port is
located on an add-in card which permits IRQs other than 3 or 4 to be selected,
you could configure the COM3 serial port to use a different (available) IRQ in
your system, say, IRQ5. After making the necessary changes to the card (for
example, adding or removing some jumpers or adjusting the positions of some
switches), the last step would be to configure Windows to monitor IRQ5 rather

B-8



PC Serial Ports

than IRQ4 for the COM3 serial port – this is accomplished using the Windows
Control Panel under the “Ports” option (see your Windows documentation for
details).

If you attempt this solution, you must be certain that you do not choose an IRQ
which is in use by some other device in your system – if so, you will only trade
one type of IRQ conflict for another. You should be aware that many common
add-in cards use IRQs, including network cards and multimedia sound cards,
both of which are commonly used under Windows. Your PC hardware vendor
can assist you in configuring IRQs. You may also need to consult the
documentation for your PC and any add-in cards which are installed to
determine which IRQs, if any, are available on your system.
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Selecting an Add-In Serial Port Card

This section presents advice on how to choose an add-in serial port card for
use with PassageWay. Because PassageWay does not have any unique
requirements with respect to serial ports, this advice applies generically to
selecting a serial port for use with any peripheral.

In general, there are two main things to consider when selecting a serial port
for use with PassageWay:

1. Choose a card which offers the flexibility to configure its serial port IRQs
to values other than IRQ3 and IRQ4 (for example, to IRQ2 or IRQ5).

This capability often proves to be very beneficial, especially if you are
purchasing the card to add a COM3 and/or COM4 port to your system.
As described at length in “Workarounds and Solutions to the IRQ
Conflict Problem,” for PCs which do not support IRQ sharing (which
includes most PCs, unfortunately), the ability to relocate the IRQ for
COM3 or COM4 away from the defaults (IRQ4 and IRQ3, respectively)
represents the only direct solution to conflicts which may arise when
attempting to use COM1 along with COM3 or COM2 along with COM4
under Windows.

If you know your PC does not support IRQ sharing, or if you are not
sure, it's a good idea to purchase a card with this capability. If you
know your PC supports IRQ sharing, this capability is not as potentially
important.

2. For best performance with PassageWay, choose a card which has
hardware support for high-speed communications.
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PassageWay operates at a relatively high data rate (19.2 kbps, or
19200 baud), and it relies on Windows to manage the flow of data
through your PC’s serial port. Depending upon your configuration,
Windows may have problems maintaining high data rates through
traditional serial ports. In these situations, a serial port designed for
high-speed communications can eliminate such problems while
providing a reduced load on the microprocessor (thus increasing the
performance of Windows during data transfers relative to standard serial
ports). In most cases, the price differential for such a card is quite
modest and a worthwhile investment.

Many serial port cards on the market (and most built-in serial ports) use
either the 8250 or 16450 Universal Asynchronous Receiver Transmitter
(UART) as their key component. Although these UARTs can operate at
high speeds, they do not assist the PC’s microprocessor in dealing with
high-speed data transfer. Under Windows, in particular, data can be
lost at high baud rates using these UARTs. If this data loss occurs,
PassageWay cannot function properly.

Whenever possible, select a serial port card which uses the 16550
UART. This industry standard UART is an improved version of the
16450 with hardware support to help offload the microprocessor during
high-speed data transfers. Windows 3.1 has built-in support for the
16550, so no special software configuration is required to obtain the
benefits of the 16550’s enhanced capabilities. In addition, any high-
speed peripheral can benefit from the 16550 (for example, a 9.6 kbps or
14.4 kbps data and/or fax modem), not only PassageWay.

In general, since there is no way of knowing ahead of time if your
particular PC configuration requires an enhanced serial port for
PassageWay, AT&T strongly recommends that you purchase a card
based on the 16550 UART to insure trouble-free operation with
PassageWay.
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Glossary

A

AT&TCall
A card file application that enables you to maintain information such as names,
addresses, and telephone numbers.

AT&TConnect
Application that manages AT&TCall and AT&TSet and ensures correct
operation of the serial port to which your PassageWay Adapter is connected.

AT&TSet
Application that enables you to program user features for your MLX-28D, MLX-
20L, and MLX-10DP telephone from your PC.

B

bank
The collection of cards in an AT&TCall file.

C

call log
A PassageWay file that stores an entry of every call you make from the Dial
buttons of a card or Quick Dials in an AT&TCall file.
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call log archive file
A file in which you may store call log entries. This is an ASCII file in which
each field of data is separated by a tab.

card
A data record in an AT&TCall file. This record contains a maximum of 13 data
fields.

comma separated values format
A data file that contains records consisting of horizontal fields of data. Each
field of data is separated from the next field by a comma (,).

D

dialpad window
A window in AT&TCall that functions like the dialpad on your telephone.

L

GL-2

Log Viewer
An application that enables you to view call entries that are stored in the
PassageWay call log.
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setting in an AT&TCall file, 3-56

always on top,
setting, 3-58
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Quick Dial, 3-68
assigning a phone number to a

Quick Dial, 3-69
card tasks, 3-62
changing the field labels in cards, 3-62
changing the number of Quick Dials
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creating a new file, 3-43
creating a new card, 3-63
deleting a card, 3-64
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Quick Dial, 3-72
editing an existing card, 3-65
erasing a Quick Dial, 3-73
exiting the application, 3-44
exporting information, 3-44
file tasks, 3-40
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hiding the card display, 3-66
importing files into AT&TCall, 3-46
making a call from the dialpad, 3-43
making a call from a card, 3-65
making a call from a Quick Dial, 3-72
menu descriptions, 3-75
menu tree, A-2
opening files, 3-49
printing a card list, 3-50
printing a card, 3-51
printing a file, 3-51
programming a phone number to

a Quick Dial, 3-69
removing a password, 3-55
re-assigning an existing

Quick Dial, 3-73
running the application, 3-39
saving a file, 3-56
selecting a card, 3-66
setting a password for a file, 3-54
setting the account code options, 3-56
setting the dial options, 3-58
setting window to always be

on top, 3-58
setting a file to be loaded

automatically, 3-59
showing the card display, 3-66
sorting cards in the bank, 3-41
tasks, 3-40
troubleshooting, 8-12
tutorial, 3-10
using the timer, 3-66

AT&TConnect,
accessing the events log, 6-4
changing the COM port, 6-6
changing the system configuration

information, 6-7
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description, 6-2
menu descriptions, 6-10
menu tree, A-5
running the application, 6-2
testing the PassageWay adapter, 6-8
troubleshooting, 8-2

AT&TSet,
accessing the current programming

from your telephone, 4-10
changing the button labels, 4-11
converting a file to a different button

configuration, 4-13
creating a new file, 4-15
description, 4-2
exiting the application, 4-16
inspecting a button, 4-16
menu options, 4-33
menu tree, A-3
opening an existing file, 4-18
printing button labels, 4-18
programming a button, 4-20
programming your telephone, 4-23
running the application, 4-7
saving a file, 4-24
selecting buttons to be programmed to

your telephone, 4-26
setting non-button features, 4-27
setting non-button ringing, 4-29
tasks, 4-10
troubleshooting, 8-14
writing a file to your telephone, 4-23

autodialing applications,
helpful hints, 7-4
using with PassageWay, 7-1

B

button labels,
changing in AT&TSet, 4-11
printing in AT&TSet, 4-18

C

call log,
deleting entries from, 5-6
description, 5-2
printing entries from, 5-8

COM port,
changing the COM port, 6-6

COM ports,
overview, B-1
verifying the number of active ports in

your system, 8-2
converting AT&TSet files, 4-13

D

dial option,
setting in AT&TCall, 3-58

dialpad,
making a call from, 3-43
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E I

events log, importing,
accessing, 6-4 AT&TCall, 3-46

exporting, installation,
AT&TCall information, 3-44 overview, 2-1

installing,
PassageWay adapter, 2-5

F PassageWay software, 2-7

field labels,
changing in AT&TCall, 3-62

file tasks,
AT&TCall, 3-40

H

helpful hints,
AT&TCall, 3-38
autodialing applications, 7-4
Log Viewer, 5-4

L

Log Viewer,
accessing from the AT&TCall

application, 3-40
deleting entries from the call log, 5-6
description, 5-2
helpful hints, 5-4
menu descriptions, 5-14
menu tree, A-5
printing log entries, 5-8
running the application, 5-5
setting the preferences, 5-8
sorting call log entries, 5-10
specifying calls to be displayed, 5-12
tasks, 5-6
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M

menu tree,
AT&TCall, A-2
AT&TConnect, A-5
AT&TSet, A-3
Log Viewer, A-4

N

non-button features,
setting, 4-27

non-button ringing,
setting, 4-29

notes,
accessing in AT&TCall, 3-62

P

PassageWay,
components, 1-3
installation overview, 2-1
overview, 1-1
overview of applications, 1-2
requirements, 1-6
system requirements, 2-4
user responsibilities, 1-7

PassageWay adapter,
installing, 2-5
testing, 6-8

PassageWay software,
installing, 2-7

password,
administering for an AT&TCall file, 3-54
removing from an AT&TCall file, 3-55

printing,
AT&TCall card list, 3-50
AT&TCall card, 3-51
AT&TCall file, 3-51
button labels in AT&TSet, 4-18

programming your telephone, 4-23

Q

Quick Dial,
accessing information about, 3-68
assigning a phone number to, 3-69
changing the number displayed, 3-71
changing the setup of the labels, 3-71
dialing a phone number from, 3-72
erasing, 3-73
making a call from, 3-72
programming a phone number to, 3-69
re-assigning an existing

Quick Dial, 3-73
tasks, 3-68
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S

serial ports,
overview, B-1

system configuration,
changing, 6-7

T

tasks,
AT&TCall, 3-40, 4-10
card, 3-62
Log Viewer, 5-6
Quick Dial, 3-68

technical support, 1-9
timer,

using in AT&TCall, 3-66

W

writing a file to your telephone, 4-23
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Printing Your Button Labels

4.

Select Print Labels... from the File
menu. The Print Labels dialog box
appears.

1.

2.

3.

Select the checkbox of the quadrant
where you want the labels printed on
the page.

Select whether you want the outline
of the buttons printed. If you are
printing the labels on a plain sheet of
paper, select the checkbox for Print
form outline. If you are printing the
labels on a perforated AT&T button
label form, do not select the
checkbox for Print form outline.

Select the OK button.

PassageWay™ Solution
For MERLIN LEGEND®

Communications System

Log Viewer

Specifying Calls to be Displayed
AT&TCall

To specify calls to be displayed:
1. Select Filter/Sort Options... from

the View menu. The Filter/Sorting
Options dialog box appears.

2 .  Select the filtering options you want.
3 .  Select the OK button.

Deleting Entries from the Call Log

To delete entries from the Call Log:
1. Select the entries that you want to

delete from the Log Viewer window.
The entries you selected are
highlighted.

2. Select Move to Archive from the Edit
menu if you want to save these
entries to the Call Log archive file, or
select Delete from the Edit menu if
you want to delete these entries
without adding them to the archive
file.

On-Line Help

To access on-line help for any of the
PassageWay applications, access the
Help menu or press [ F1 ]. 

Quick Reference

Making Phone Calls

From a Card
To make a call from a card:
1. Select the card that contains the

phone number you want to dial. The
selected card is displayed.

2. Click on the Dial button located to
the right of the phone number that
you want to dial.

From a Quick Dial
To make a call from a Quick Dial, click on
the Dial button of the Quick Dial in which
you are interested.

From the Dialpad
To make a call using the Dialpad:
1.

2.

3.

Select the Dialpad button. The
Dialpad window appears.

Press [ ALT ]-[ K ] on  your  keyboard or
select the Speaker button. Your
speakerphone goes off-hook, and
you hear a dial tone.

Using your PC keyboard or choosing
buttons in the Dialpad window, enter
the phone number.

Creating a New Card

To create a new card:
1.

2.

3.

4

Select the New Card button. The New
Card window appears.

Enter your information.
When you are finished, select the Add
Card button.
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Editing an Existing Card

To edit an existing card:
1. Select the card you want to edit. The

card is displayed.
2. Select the Edit Card button. The Edit

Card window appears containing the
current information for the card.

3. Make the changes to the card.
4. When you are finished, select the

Return Card button.

Entering Notes in a Card

AT&TSet

To enter notes on a card:
1. Select the card in which you want to

enter notes. The selected card is
displayed.

2. Select the Show Notes button. The
Notes field appears.

3. Enter information in the Notes field or
modify the existing information (if any)
in the field.

4. When you are finished, choose the
Hide Notes button.

Assigning a Phone Number to a Quick Dial

To assign a phone number to a Quick Dial:
1.

2.

3.

4.

5.

Select the card that contains the
telephone number that you want to
program to a Quick Dial. The selected
card is displayed.
Press and hold down [ SHIFT ]  , and
then click on the Label button of the
Quick Dial that you want to program.
The Create Quick Dial dialog box
appears.
Enter the label that you want to
appear on the Label button of the
Quick Dial.
Select the option button of the
telephone number that you want this
Quick Dial to dial.
Select the OK button.

Re-Assigning an Existing Quick Dial Button

To assign a new phone number to a
programmed Quick Dial:
1.

2.

3.

Select the card that contains the
telephone number that you want to
program to the Quick Dial. The
selected card is displayed.
Press and hold down [ SHIFT ]  , and
then click on the label button of the
Quick Dial that you want to change.
The Change Quick Dial dialog box
appears.
Select the Create New button. The
Create Quick Dial dialog box
appears.

2

4. Enter the label that you want to
appear on the Label button of the
Quick Dial.

5. Select the option button of the
telephone number that you want this
Quick Dial to dial.

6. Select the OK button.

Programming Your Telephone

To program your telephone:
1. Open the file that has the feature(s)

you want to program to your
telephone. The selected file is
displayed.

2. Select the button(s) that you want to
program. The button position
becomes highlighted and displays
use.

3. Select Write to Telephone... from
the File Menu. The selected features
are programmed to your telephone.

Programming a Button

To program a new button or change the
feature of a button that has already been
programmed:
1.

2.

3.

4.

5.

Select the button label that you want
to program. The button label
becomes highlighted.
Select Change Button Programming
from the Programming menu. The
Change Button Programming dialog
box appears.
Select the option button of the
feature that you want to program to
this telephone button.
Select the OK button. The Program
Feature dialog box appears.
Specify the button label, and then
select the OK button.

Setting Non-Button Features

To activate or deactivate non-button features:
1.

2.

3.

4.

Select Non-Button Features... from
the Programming menu. The Non-
Button Features dialog box appears.
Select the feature(s) you want to
activate or deactivate.
Select the Use or Skip option buttons
to indicate whether you want to
apply the feature when you write this
file to your telephone.
When you are finished, select the OK
button.
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Printing Your Button Labels

4.

Select Print Labels... from the File
menu. The Print Labels dialog box
appears.

1.

2.

3.

Select the checkbox of the quadrant
where you want the labels printed on
the page.

Select whether you want the outline
of the buttons printed. If you are
printing the labels on a plain sheet of
paper, select the checkbox for Print
form outline. If you are printing the
labels on a perforated AT&T button
label form, do not select the
checkbox for Print form outline.

Select the OK button.

PassageWay™ Solution
For MERLIN LEGEND®

Communications System

Log Viewer

Specifying Calls to be Displayed
AT&TCall

To specify calls to be displayed:
1. Select Filter/Sort Options... from

the View menu. The Filter/Sorting
Options dialog box appears.

2 .  Select the filtering options you want.
3 .  Select the OK button.

Deleting Entries from the Call Log

To delete entries from the Call Log:
1. Select the entries that you want to

delete from the Log Viewer window.
The entries you selected are
highlighted.

2. Select Move to Archive from the Edit
menu if you want to save these
entries to the Call Log archive file, or
select Delete from the Edit menu if
you want to delete these entries
without adding them to the archive
file.

On-Line Help

To access on-line help for any of the
PassageWay applications, access the
Help menu or press [ F1 ]. 

Quick Reference

Making Phone Calls

From a Card
To make a call from a card:
1. Select the card that contains the

phone number you want to dial. The
selected card is displayed.

2. Click on the Dial button located to
the right of the phone number that
you want to dial.

From a Quick Dial
To make a call from a Quick Dial, click on
the Dial button of the Quick Dial in which
you are interested.

From the Dialpad
To make a call using the Dialpad:
1.

2.

3.

Select the Dialpad button. The
Dialpad window appears.

Press [ ALT ]-[ K ] on  your  keyboard or
select the Speaker button. Your
speakerphone goes off-hook, and
you hear a dial tone.

Using your PC keyboard or choosing
buttons in the Dialpad window, enter
the phone number.

Creating a New Card

To create a new card:
1.

2.

3.

4

Select the New Card button. The New
Card window appears.

Enter your information.
When you are finished, select the Add
Card button.
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